USB-C not working on Acer Chromebook Spin 714 (2023) KANO

New user - please pardon my stumbles… I just found this forum. I had previously posted about this in the chrultrabook bugtracker, I am not trying to double post, but I now think that is NOT the right place and this one is.

I have MrChromebox’s full UEFI on this machine. I have tried the small service to fix the usb-c but it is not working for me. Detail below:

What I did - created the file in /etc/systemd/system as instructed.

Description=Enable USB-C on chromebook

ExecStartPre=/sbin/modprobe -r -a cros-ec-typec intel-pmc-mux
ExecStart=/sbin/modprobe -a intel-pmc-mux cros-ec-typec


I tried to enable it:
sudo systemctl enable --now chromebook-usbc.service

It should have enabled without error, instead it failed to enable:

xyz@deb714:/etc/systemd/system$ sudo systemctl enable --now chromebook-usbc.service
Job for chromebook-usbc.service failed because the control process exited with error code.
See "systemctl status chromebook-usbc.service" and "journalctl -xeu chromebook-usbc.service" for details.

The recommended steps for more detail yielded the following:

xyz@deb714:~$ systemctl status chromebook-usbc.service
× chromebook-usbc.service - Enable USB-C on chromebook
     Loaded: loaded (/etc/systemd/system/chromebook-usbc.service; enabled; preset: enabled)
     Active: failed (Result: exit-code) since Fri 2024-04-05 15:24:31 CDT; 2min 23s ago
    Process: 1942 ExecStartPre=/sbin/modprobe -r -a cros-ec-typec intel-pmc-mux (code=exited, status=1/FAILURE)
        CPU: 7ms
sudo journalctl -xeu chromebook-usbc.service
Apr 05 15:24:31 deb714 systemd[1]: Starting chromebook-usbc.service - Enable USB-C on chromebook...
░░ Subject: A start job for unit chromebook-usbc.service has begun execution
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit chromebook-usbc.service has begun execution.
░░ The job identifier is 1981.
Apr 05 15:24:31 deb714 modprobe[1942]: modprobe: WARNING: Module intel_pmc_mux is in use.
Apr 05 15:24:31 deb714 systemd[1]: chromebook-usbc.service: Control process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support:
░░ An ExecStartPre= process belonging to unit chromebook-usbc.service has exited.
░░ The process' exit code is 'exited' and its exit status is 1.
Apr 05 15:24:31 deb714 systemd[1]: chromebook-usbc.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support:
░░ The unit chromebook-usbc.service has entered the 'failed' state with result 'exit-code'.
Apr 05 15:24:31 deb714 systemd[1]: Failed to start chromebook-usbc.service - Enable USB-C on chromebook.
░░ Subject: A start job for unit chromebook-usbc.service has failed
░░ Defined-By: systemd
░░ Support:
░░ A start job for unit chromebook-usbc.service has finished with a failure.
░░ The job identifier is 1981 and the job result is failed.

OS is Debian 12 Bookworm 64-bit
Linux deb714 6.6.10-chrultrabook #1 SMP PREEMPT_DYNAMIC Tue Jan 9 04:03:43 UTC 2024 x86_64 GNU/Linux
Coreboot Firmware version: and Device:

Acer Chromebook Spin 714 [CP714-1WN] (Kano)
FW: MrChromebox-4.22.2-5-g822782a1001
13th Gen Intel (R) Core (TM) i5-1335U
(as reported during boot, although it's actually CP714-2W-56B2)

Additional context

Acer Chromebook Spin 714 (2023)
(details courtesy PcWorld)
* CPU: Intel Core i5-1335U
* Memory: 8GB LPDDR4X
* Graphics/GPU: Intel Iris Xe Graphics
* Display: 1,920 x 1,200 60Hz LCD Touchscreen
* Storage: 256GB PCIe NVMe
* Webcam: 1440p
* Connectivity:  2x Thunderbolt 4 / USB-C, 1x USB-A, 1x HDMI, 1x 3.5mm combo audio
* Networking: Wi-Fi 6E, Bluetooth 5.2
* Biometrics: None
* Battery capacity: 42 watt-hours
* Dimensions: 12.3 x 8.8 x 0.71 inches
* Weight: 3.02

on case:
Model No.: N22Q10
Mfg Date: 2023/10/28

reported at the command line:
architecture: x86_64
board name: KANO
Cpu Model: i5-1335U
Cpu Gen: 13th


I’ve been web searching around this issue, and I found an explanation here: Adjusting keyboard brightness on VOXEL causes system freeze for what the service is trying to do:

Am I just missing that ec driver?

Maybe try a newer distro like Fedora 39. I am using NixOS unstable on Redrix and USB-C USB hotplugging works OOTB, without even using that systemd service.

I really want to get Debian Bookworm to work - its what I have on my other machines, and its what I’m most used to.

You can temporarily install a different distro just to find out if the problem is debian-specific and find a possible solution.

t2m are you still having an issue?

I think it’s working, at least I can plug in a usb-c flash drive or a small usb-c travel dock and they work. See this post in the catchall topic I started about this chromebook: usb-c fixed?

I haven’t been able to find out any more background on this problem, or this fix, beyond the post mentioned earlier in this topic. If it’s fixed at all, is every possible aspect of usb-c fixed?

I have not tried things like usb-c to ethernet, or usb-c to an external monitor yet.