Adjusting keyboard brightness on VOXEL causes system freeze

I am running arch linux (kernel 6.6.10), have run post install and am quite lost.
I think I may be having issues with my EC:

  • When I adjust the keyboard backlight brightness it has a chance of hanging the system
  • I get a trace (i think its a trace) in my system logs when i first unplug or plug a dp alt mode dock (no pd) and no video/usb (with a chance of hang)
    The usb4 service has been failing.

Sorry I am very new to forums.
If i need to send additional info that would be no problem

Thanks

Hi!

USB4 hang on TGL+ is a known bug that we have a workaround for, listed in our documentation. I haven’t had time to fix it properly in the kernel.

Hang/crash happens because EC doesn’t receive a response and to get that response, we need to load driver for Intel’s PMC MUXer (Power Management Controller) before USB-C driver for ChromeOS Embedded Controller.

I’m fairly certain if you unload cros-ec-typec and typec modules, then modprobe -v typec intel-pmc-mux cros-ec-typec it will work just fine.

I have no idea why that module doesn’t load before CrosEC, as we do have ACPI device that it binds to - just not the correct order. Adjusting modprobe configs or even DEPMOD in kernel modules did not help.

Hi,
Thanks for the response, the usb4 service I had mentioned was the one from the docs.
I have now tried the unload of the cros-ec-typec and typec modules specifically, unfortunately it is blocking on the intel-pmc-mux driver as it is “in use”. I then tried running rmmod with the -f flag to force it, but upon plugging in a charger (after loading the modules back) my system hung, which hasn’t happened before.

Is there some other thing I should do before to make this work?

Thank you for the explanation of the crash.

No worries!

If you cannot unload PMC MUX, it means that you have a fix applied and it should be working as intended :stuck_out_tongue:

It’s important to note that fix is in userspace, so please make sure to boot without any USB-C devices connected to avoid issues. Interesting to see that VOXEL has TB4, so it could be interesting to see if that causes different behavior.

Sorry, I really wish I would have more time to work on the project, but between full-time day job, personal life, hobbies and so on it’s fairly difficult as there are only three people in the project supporting Linux on those machines.

As for keyboard backlight, I’ve never had that issue (I own ELDRID). Do you adjust it using sysfs (i.e KDE slider), or ectool? Can you post backtrace you get in dmesg when that happens?

Thanks again so much for the response

I had been using the gnome (quick) settings slider and the keyboard shortcut.

Here are the dmesg logs, I don’t get a trace with the keyboard backlight but I did get one:

https://file.garden/ZWY9hW2eyH6XVY_Y/logs (zip)

I had a friend upload this but is there a file host you recommend for the forum?