Ubuntu 22.04 does not boot on Lenovo Ideapad Flex 5i (560i)

I installed Ubuntu 22.04 on a Lenovo Ideapad Flex 5i (560i), but when I boot, it shows Booting from ‘ubuntu’ failed: verify it contains a 64-bit UEFI OS. Secure Boot is disabled. I tried Boot Repair on a Live CD, but it had no effect. Nothing is shown in the UEFI Boot from File.I want to boot Ubuntu somehow.

Probably an issue with how you copied the ISO to the USB. Either use Rufus in dd mode or use Ventoy.

I created an installation media written in dd mode and installed Ubuntu, but it still does not boot.The installation media is recognized, but the SSD (Ubuntu) is not.

I had this problem… I solved installing on a microsd card and using an usb adapter.
There is an issue opened to address this issue.


Ubuntu is not supported.
In this case its probably an old version of GRUB thats broken on Coreboot

What distributions can I install and boot without problems?


I think using a pc with no external disk,i mean literally only 2 disks physically in the pc:
-Usb boot drive
-drive you want to install on
Otherwise ubuntu will try on install it to a window drive or something(on windows laptop).I got it to work this way, but audio might be a issue on alder versions.
*you will need another laptop/desktop to get this done

*The cause of your problem might be some weird attempt of Ubuntu to dualboot with chrome os

wt1682 I similarly was having issues with all flavor of Ubuntu not recognizing my hard drive on the Lenovo Gaming Ideapad. I switched to Fedora and haven’t had any problems since.