Linux not picking up hard drive in live installation

When installing linux through’s methoood (i have disabled write protection) i boot into the usb and the internal drive is not detected by linux. ive tried pop_os, linux mint and ubuntu and im trying manjaro in a bit. is this known and is there any way to fix it?

Which Chromebook?

Lenovo 100e 2nd gen

What firmware version are you running?


also here is a screenshot: EDIT: Ive clicked on select a storage device and nothing comes up

another thing, when i boot up linux, im required to use the ‘noapic’ boot parameter. is this causing an issue?

I asked because there was an old issue affecting Stoney Ridge Chromebooks not recognizing the internal drive on Linux, but that has been fixed in newer versions of the firmware.

Maybe you unplugged something when disconnecting the battery to disable write protection?

When you installed the mrchromebox firmware, did you install the Full UEFI ROM or RW_Legacy? We recommend Full UEFI.

Same thing is happening with me, on a Lenovo Flex 5i (TAEKO)
When I restore ChromeOS the internal storage works fine. But on linux, or windows didn’t show up.

Screenshot from 2024-05-05 00-33-39

@MrChromebox might be worth taking a look at

Board name? As shown in script menu / UEFI settings menu

Could you check if the disk you want to install on is not mounted?
If you have gparted see if it is visible there.

Mine is TAEKO (Lenovo Flex 5i).

Even in the boot menu didn’t show the internal drive, or when use lsblk. It’s like the slot was empty.

if you look at my post, I wasn’t replying to you. I can tell yours from the script menu screenshot =D

1 Like

Sorry, I thought was like an “automatic reply”.

RE: The Lenovo are you switching drive types from an eMMC to NVMe drive? For a different Lenovo model I had to follow these instructions to change some firmware values:

But TBH I don’t know if that’s relevant for your model or not.

Did you remove the SSD(M.2)(at-least that is what my flex 5i uses) or if its disconnected in some way.If you didn’t do that it’s probably software/firmware issue?
It should show up like this on lsblk
nvme0n1 259:0 0 119.2G 0 disk

Mine didn’t show up even inside the BIOS menu. I think is a firmware issue, because works fine when I roll back to Chrome OS.