My Chromebook restarts infinitely after installing Ubuntu

Hi. I installed Ubuntu, and the OS was working fine on my Chromebook. While finishing the Ubuntu installation, I got the recovery screen with an exclamation mark. I pressed Ctrl + L to boot from the disk to use ubuntu. After closing my Chromebook and reopening it, I noticed it was restarting infinitely.

I attempted Ctrl + L, but it didn’t work. The screen kept opening and closing, and the light near the USB-C port was like: open, close, open close… Like the screen. I then tried Esc + Refresh + Power, and the Chromebook displayed a message asking to insert a recovery USB stick or SD card.

I used the ChromeOS recovery utility to flash ChromeOS back onto the device. After the process, my Chromebook indicated that ChromeOS was successfully installed. However, upon restarting, I still encountered the same problem.

Returning to the recovery USB/SD menu, I pressed Ctrl + i, and here is the information I received:

HWID: BABYTIGER C6D- blablabla
Recovery Reason: 0x02 / 0x00 recovery button pressed
UbSD.flags: 0.0003cc74
VbNv: 60 10 00 blablabla
dev_boot_usb: 0
dev_boot_Legacy: 1
dev_default_boot: 0
dev_boot_signed_only: 0
dev_boot_fastboot_full_cap: 0
TPM: fwver=0x00010001 kernver= 0x00010002
gbb.rootkey: 454 blablaba
gbb.recovery_key: 2c8 blablabla
read-only firmware id: Google_Coral.10068.82.0
active firmware id: Google_Coral.10068.82.0
TPM state: v=1 failed tries=0 max_tries=200

My Chromebook is an ASUS Chromebook C523 and i used the MrChromebox fireware

Can anyone can help me please? i want to use my chromebook at school but i can do nothing rn. Thanks you

Update: i unplug and plug the battery, nothing changed.


While I’m not strongly familiar with RW_Legacy, it sounds like if you’re trying to go back to full stock, I believe you need to undo the flags set by the script, as it looks like it tells the chromebook to boot into legacy mode by default.

Also, it sounds like according to MrChromebox’s site you need to be hitting ctrl + D to be booting into chromeos, not ctrl + L.

1 Like

Rip school chromebook


@theplug09 In the future, please do not make and delete posts complaining about no response, and also don’t add things like “PLEASE HELP ME RIGHT NOW” to the post title. It is spam.


lol it my personal chromebook but i want to use it for school so…snif snili snif XD

sure sorry

mh… i understand. But the problem is it restart everytime, and on the sd n usb screen, i cant use the ctrl d and other

So the screen is like : work, close, work, close. Nothing on the screen, all black.

This is the screen when i do the esc refresh power.

And this is the screen when i do the ctrl i.

I do like 6 recovery, nothing work. Help!

are guy can help me pls :frowning:

since 2 day im waiting

If you would give around five minutes to read the documentation, you would notice a tip on page Booting the Recovery USB | Chrultrabook Docs - which says that you need to disable write protection once again, so the firmware can be updated while recovery process is running.

Also, please stop spamming in the unrelated topics.

They already mentioned they tried this in the original post

(You also dont need to disable wp in the first place for rw/legacy)

What happens if you try to enter secure mode? Does it let you?

let me explain, when the installation of ChromeOS was done, it said : installed with success or something like that. But still the same problem! it restart restart and restart! Like nothing on the screen, just a screen black, and it close. My chromebook can do it for hours! I read the doc, that what i do! i cant even switch to secure mode.

Also, i was checking for a Suzy-Q debug cable, but the production is discontinued. (i even check ebay, but nothing!). I was checking for a usb programmer too, but i cant because my chromebook is 2019.

Im very desperate, my mom pay 300$ for this Chromebook, she buy it for my school, game n shit.

If any other solution, it would be cool :frowning:

If it just keeps restarting this sounds like a hardware issue.

how can i get a hardware issue by just making ubuntu into sleep mode? Ubuntu was working fine until i close my chromebook without completely shutting down it

if this information can help, after the installation , i got the ! screen and press ctrl l to select ubuntu.

Ubuntu isnt supported

No, it doesn’t help, because you’re trying to recover ChromeOS, which has nothing to do with booting Ubuntu using Ctrl+L.

If the recovery process is seemingly successful but in reality you cannot boot ChromeOS, like Ethan said, it sounds like a hardware issue, maybe a problem with the eMMC.

It may help if you explain what exactly you are doing on startup to boot ChromeOS.

By simply click on the power button. after it restart restart restart.