Linux not picking up hard drive in live installation

I went through this on the same board back about a year ago, had to wait for 4.20 firmware to be released to try and then couldn’t find the internal eMMC. Since the eMMC is connected through a PCIe4 port, you can just replace it with any nvme 2242 SSD and it will work fine.

Mrchromebox told me when I was first having this issue that it was due to an eMMC driver not available at the time and that future updates to alder lake could improve that.

1 Like

no, the device appears to the firmware as a NVMe device, since it’s using a NVMe to eMMC bridge. It’s possible that bridge device needs some tuning on the coreboot side.

I just tried the Ganondwarf solution, changed to another NVMe SSD and it was detected in BIOS. With that, I was able to install every OS I tried (Arch, Debian, Ubuntu, and also Windows), which worked flawlessly.

if someone in the US has one of these problematic NVMe->eMMC drives and wants to lend it to me for debugging, just sent me a PM