Linux Mint Edge no audio / USB4 on VOLMAR (Vero 514)

Just picked up a VOLMAR (Acer Vero 514) a couple of weeks ago, and hoping to get Linux Mint on it. Just since I use Mint on a couple of other machines.
I chose the Linux Mint 21.2 Edge image since it is running the 6.2 kernel.

Installed the RW Legacy firmware (thank you Mr Chromebox).
Created bootable USB (had to use Yumi in Windows to make it work) with persistence.
Got in to Mint, and followed the Post Install instructions by running the audio script.
Rebooted, upon completion of the install.

No audio - still just seeing Dummy Output.

lspci -nnk | grep -A2 Audio provides the following result :

00:1f.3 Multimedia audio controller [0401]: Intel Corporation Alder Lake PCH-P High Definition Audio Controller [8086:51c8] (rev 01)
DeviceName: Multimedia audio controller
Kernel driver in use: sof-audio-pci-intel-tgl

Is it possible to get audio running on this Alder Lake device in Mint using the RW Legacy bootloader? I don’t have a Suzy-Q so am unable to install the UEFI firmware at this stage.

Next I tried the USB4 fix from the Post Install page.
After running systemctl enable --now chromebook-usbc.service, I received the following message :
Created symlink /etc/systemd/system/ → /etc/systemd/system/chromebook-usbc.service.
Job for chromebook-usbc.service failed because the control process exited with error code.

I notice Ubuntu-based distros are listed as having potential issues. Is that what I’m running into?

At the moment I am attempting to update the kernel to 6.5.
Any other tips from anyone?

Chrultrabook kernel offers 6.6. Installing Linux | Chrultrabook Docs has an audio script that should work on Mint and also ask you if you want the Chrultrabook kernel. There’s also a note on Supported Devices and Platforms | Chrultrabook Docs about USB4, touchpad, and such.

oh forget I said some of that. sounds like you already tried

I’m wondering if my issues are stemming from the fact I am running Linux from Live USBs. I have set persistence for each bootable image (moved over to using ventoy).

My goal was to ensure audio was working before installing over ChromeOS. Audio is vital to my usage.

Could the issue be that audio won’t set up properly because I’m running from a live USB?
Have tried Mint 21.2 Edge (6.2 kernel) and EndeavourOS (6.6 kernel). Same result in both. Running the audio script completes, tells me to reboot, but upon reboot, I still have no audio. Other changes (wifi, key backlight script etc) persist - so I know the persistence file is working.

Just making sure - you do have the Chrultrabook kernel as an option, right?
For me, using either Mint 5.15 kernel or Chrultrabook kernel and Xfce on my Lenovo 500E Phaser360S was fine

No, I haven’t seen any Chrultrabook kernel options. I just downloaded the regular distro ISO images.

Where does the Chrultrabook kernel come in to play?
Didn’t see it mentioned on Installing Linux | Chrultrabook Docs

If the audio script didn’t give you the option to install it, there’s the download on Index of /public/chrultrabook/debian-kernel/ (Mint is close enough to use Debian)

I’m not sure if the kernel is your issue though. If it works, it works, if it doesn’t, it doesn’t. I haven’t done much reading on RW Legacy Bootloader or USB with persistent storage - just curious, would a full install to USB be different than live session?
I’ve installed to USB before with the SD Card carrying the live session / installer

Yes a full install is very different. I’m not going to support live images, just install it.

1 Like

Oh, interesting

In that case install to USB. Plug in 2 USBs, or 1 SD Card, 1 USB, and install Linux Mint to the USB. Done it before with Debian - this could be helpful: Full Linux install to USB potential problem and solution
You’d need 1 live session, 1 free USB, and do custom partitioning to install to the free USB

If it’s like my Phaser360S, you can get away with 2 partitions:
EFI (50 MB)
ext4 (rest of free space) on /
Make sure you selected the correct USB; it may be called “sda” and have the name of the USB
edit: by USB I mean only Flash Drive capable of storage. A B C are connector types and don’t have storage

First - thanks for the confirmation @WeirdTreeThing - I appreciate you letting me know.

Second @VaporTrail, I may give that a go. I’m currently travelling and only have the 1 USB drive that is large enough - the other is just a 4GB stick. Also this device only has 1 USB A port, so I would need an adapter for the USB C. Perhaps it will have to wait until I’m back home in a couple of weeks. Got everything I need there to do it…If I don’t just do a full install first :wink:

OK - I went for the full install of Mint Edge.
After install I updated the system, which installed kernel 6.5

Ran the audio script - still nothing :frowning: I just get the same Dummy output.
I have tried running the script a second time, but it seemed to make no difference. Each time, the script reports that the audio is now installed and that I just need to reboot.

However the reboot still yields in no audio.
Any tips?

I also installed EndeavourOS in a dual-boot configuration. Script did not produce audio from that OS either. It was running kernel 6.7. I wonder if the issue is realted to RW-Legacy boot (don’t have Suzy-Q so can’t remove WP).

Script didn’t generate a tar.gz, but a log file. Didn’t see any Wifi specific info, so uploaded to Jan 18 8:38 PM - Codeshare for 24 hours.

Thanks for looking into this @WeirdTreeThing

NVM - guess I needed to supply sudo password to terminal for it to complete.
Here is the tar file.

Did you spot anything of note in these logs @WeirdTreeThing ?

Somehow the HDA driver is loading instead of SOF.

Any idea on how I can rectify that on Linux Mint and EndeavourOS?
Is the correct driver already in the system, but just not loading, or do I need to download driver files and instruct the OS to use them during boot?

See what happens when you add this to /etc/modprobe.d/sof.conf

options snd-intel-dspcfg dsp_driver=3

Thank you for the suggestion.

In both Mint & EndeavourOS, this file did not exist.
I created it in each, but it appears to have made no difference.

In Mint I just see the Dummy device, and Endeavour displays a speaker icon with a red line through it.

Send dmesg on endeavour.

OK, here is the data dump from EndeavourOS.