Help need with Pop OS sound fix

keep in mind I’m not that experienced with Linux.I need help getting the sound to work on me Lenovo ideapad flex 5i with PoP OS installed running from an usb.This is the output when i run inxi -SMA:System: Host: pop-os Kernel: 6.8.0-76060800daily20240311-generic x86_64 bits: 64 Desktop: GNOME 42.5 Distro: Pop!_OS 22.04 LTS Machine: Type: Desktop System: Google product: Lindar v: rev3 serial: <superuser required> Mobo: Google model: Lindar v: rev3 serial: <superuser required> UEFI: coreboot v: Google_Lindar.13672.291.0 date: 02/18/2022 Audio: Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: sof-audio-pci-intel-tgl Sound Server-1: ALSA v: k6.8.0-76060800daily20240311-generic running: yes Sound Server-2: PipeWire v: 1.0.3 running: yes.If i need to run other command please tell me.

Oh, I am having a similar issue. JUST put Debian 12 on my Acer Spin 713 (voxel) and the audio isn’t working. I have tried running the recommended commands and it still doesn’t work.

I have Git and Python, Have you checked that you have those?

Im currently switch to a different distro in hopes it might work,Yes I ve basically tried alot of the possible fixes in different forums but still nothing.The only time the sound worked was in a persistent live xubuntu with a script posted on github.I currently am using RW_legacy so that my Chrome OS is still intact.

Don’t you need a custom kernel or something to get the audio working?

I am going to hopefully get this shutdown soon as I might just move to Xubuntu.

I have no clue. Not that I can find, if someone has the correct answer I’d love to hear it, in plain English cause my techobabble is seriously out of practice.

Having worked at System76 in the past, I can definitely say that Pop!_OS has certain oddities here and there that other distros won’t have, such as their cpu-scheduler having issues occasionally. Is there anything tying you to this distro?

The audio script does not support live environments.

yes just checked but also It doesn’t support ubuntu.I am currently on Xubuntu.NOTE:I tried the audio script on POP_OS but it did not work.

Has anyone tried to use the same files that make the crostini audio work on these other OS’s?

The sound is still disfunctional.

Crostini uses chromeos’ audio server, so the configuration used there is useless outside of chromeos.

Once again, the audio script does not support live environments.

Not on a live environment,one that I actually installed to my usb,im not saying persistent,Its a full install(on my usb).

Ok good to know

I have a question if anyone is willing to answer it:does sudo apt upgrade update the kernel?because if it doesnt’t then i could be a kernel issues.

I ran the sound script on a fresh PoP OS installation,I did not preform a sudo apt upgrade.My kernel is the default one that came with the iso which is 6.8.0-76060800daily20240311-generic . Yet the sound doesn’t work still:dummy output is the only option.would you like me run futher commands to debug this?
I get a lot of error message looking things when I run journalctl -k | grep -Ei "ALSA|HDA|sof[-]|HDMI|snd[_-]|sound|hda.codec|"

Its getting annoying to the point where it seems to prevent booting to login screen.

You do need a custom kernel, as mentioned on this page

See this page

We have tried that and found that with my computer it doesn’t work. My husband found a YouTube video that proves it works but only with Bluetooth speakers and headsets. Hopefully they will get here today.

It’s an issue between Debian and the computer (Acer spin 713-VOXEL). I chose Bluetooth cause I didn’t want to have to redo all of the other stuff that is setup and working.