Disable firmware write protect from Linux using SuzyQ cable

Hi,

I have an HP x2 SORAKA tablet on which I successfully ran the firmware-util.sh script several years ago. Since it was a bit of an experiment, back then I put it into legacy BIOS mode, as I wanted a way back to ChromeOS. Recently I decided I wanted to “upgrade” it to UEFI and just run Linux on the machine. I’ve tried running the latest version of MrChromebox’s firmware-util script. I’m running the script from inside my Ubuntu 24.04 installation on the machine itselft. I tells me Fw WP: Enabled.

Since this is a Chromebook that’s not easily disassembled, I’m trying to disable the write-protect using my SuzyQ (compatible) cable and through dmesg I can see it successfully connecting and the USB devices show up as expected. I then try to unlock/disable it per the instructions provided:

echo "wp false" > /dev/ttyUSB0
echo "wp false atboot" > /dev/ttyUSB0

I’ve also tried using:

echo "ccd open" | sudo tee -a /dev/ttyUSB0 > /dev/null

… to change the CCD status from Closed to Open.

After executing this I’ve rebooted the laptop/tablet and re-run the firmware-util.sh script. However, for whatever reason, I’m not able to get Fw WP to go into Disabled mode.

I’ve read and re-read the instructions and tried multiple ways to update my device, but to no avail. What am I missing? Can the write-protect only be done from ChromeOS?

Thanks in advance for any ideas, pointers, recommendations.

You still need to disconnect the battery to allow the ChromeBook to disable the write protect. Running the script FW from Linux on the ChromeBook is fine.

djb

follow the CR50 guide

-but looks like you’re missing the sudo gsctool -a -o part with the PP pressing

REF: Disabling write protect with a SuzyQable | Chrultrabook Docs

Yeah, I no longer have ChromeOS on the device, so the gsctool is not available to me. I guess I’ll have to restore the ChromeOS installation and go back through the setup. Now, my only issue is that I no longer have my original backup of the ChromeOS image. Although, from what I read, there should be stock images available that may work.

Thanks for the input.

Using Linux on a separate device to disable HWWP

Install screen in Linux terminal, if needed
sudo apt install screen

Connect the Chromebook and Linux device
Insert the USB-C end of the SuzyQ cable into the Chromebook
Plug the USB-A end into the Linux device

In the Linux terminal, check that the SuzyQ cable is inserted correctly
ls /dev/ttyUSB*
Output should list ttyUSB0, ttyUSB1, ttyUSB2

Connect to the Chromebook via Screen
sudo screen /dev/ttyUSB0

Disable HWWP
ccd open
wp false
wp false atboot

Reset CCD to factory
ccd reset factory

Unplug SuzyQ cable to end the Screen session

you can’t open the CCD without either using gsctool or booting with the battery disconnected. That’s the problem the OP is facing. They either disconnect the battery or go back to ChromeOS and unlock there.

I thought that was kind of the point of using the suzy q so that you don’t need to open up the unit? I must have never noticed because usually the device I’m working on is already taken outside of the unit and therefore not connected to a battery…

Good to know, thanks.

you don’t need to open the unit, as long as the device is still running ChromeOS

1 Like

just download gsctool. You can get it from Index of /files/utils/.