Could someone help me get the sound working on Lenovo Ideapad flex 5i

Switching back to POP OS to test a possible fix.

Nope, no one can help you.

What about POP OS?
I switch back if it possible to fix,or another OS that can be fully installed on a USB,Idealy with apt,and most importantly with systemctl because I need my usb c ports working.

Modify the script to treat Ubuntu as debian it might work. If it doesn’t, easier to install a different distro

I am really not that experienced so I might switch to endeavour OS.

Read what the script does and do it yourself manually lol

If you mean the sound script I already ran it on Xubuntu and it didn’t work.
I removed the references of ubuntu in the script.In fact It didn’t work in POP OS which was supported so my chromebook might have some specific other fix.

Where is it stated that pop os is supported?

Have you tried any other distro that isn’t Ubuntu based to get to the “root cause” of the issue?

For the end user, there is no advantage in using just plain Debian over Ubuntu nowadays

Erm it says on my readme that poopos is supported

Ah I forgot about that, have fun supporting it

Pop actually updates things like ucm and the kernel. I’ve seen no pop-specific issues so far.

Nice, I was just saying that since in the docs it doesn’t mention pop at all for being a special case

I shall make another rare WTT PR then

what is WTT PR?anyway I thought debian is to tedious to get setup with the grub issues that I saw on veronica explains youtube vid.It would be nice if there was a straight forward guide on how to fix that.
Maybe LMDE 6 would work.

Personally, I would recommend Debian or Fedora over Ubuntu anyday…also System76 might make an unexpected change to Pop!_OS randomly that could cause things to break. Having worked for them in the past, I can say it can happen.
Is sound working in Fedora or Debian? If not, does the audio script help there?

I will try to try out LMDE tomorrow if possible.Then arco linux if needed and finaly fedora as a last resort.

Be sure to run that script after installing any distro, and then reboot to test.

Thats what I do every time but also I won’t preform a sudo apt upgrade to save time.

LMDE was unsuccessful on my usb,Didn’t boot after finishing installation,will try arco linux next.