Can I Install Windows in RW_Legacy mode?

I have a Chromebook SARIEN (Dell Latitude 5400) that does not support full UEFI, but supports RW_Legacy.

Can I install Windows in RW_Legacy?

Otherwise, can I somehow install full UEFI firmware in this laptop?

No, and no. Sorry.

Turns out that I could install Windows 11 in the RW_Legacy mode, without any further tweaks.
Audio works out of the box. The USB ports are working.

Touchpad and Keyboard are not working. Wifi is not working, and it is using some basic graphics (1024x768 resolution). This computer has an i5 processor with integrated graphics, and should be able to provide much higher resolution.

I will try installing drivers and get back after sometime.

BTW, why is installation of full UEFI not possible on this laptop?

That’s not the experience you will have on most Chromebooks. I have tried just for fun to boot the Windows installer ISO using RW_LEGACY and it will BSOD within 30 seconds.

You should prepare yourself for the eventuality that a lot of basic functionality will not work, even if you do manage to get some of it working. Anyhow, CoolStar doesn’t provide support for installing Windows with RW_LEGACY so you’d be on your own.

I previously installed tiny11. Replaced that with full Windows 11. Did not encounter any BSOD during installation.

Results:
Wifi, bluetooth and audio worked out of the box.
Windows update installed the Intel UHD Graphics 620 driver (This Chromebook has an i5 processor).Night Light works too.

What does not work: Battery management (it charges, though), brightness, keyboard and touchpad.

After installing touchpad driver from Chromebook CROTA (this is the closest device I could found), touchpad worked for ~5 seconds and stopped working.

Installed keyboard driver from Coolstar’s website, but keyboard still does not work.

However, after installing these drivers, Computer Management detects touchpad and keyboard. It is just that they do not work at all.

Update: The keyboard backlight became activated after installing driverinstallers/wilcoec/wilcoec.1.0-installer.exe at master · coolstar/driverinstallers · GitHub. But the keyboard itself is not working. Keyboard backlights are going off and on. Sometimes they can be controlled with left alt + brightness keys, but no other keyboard keys are working.

Things that still do not work: Touchpad, keyboard, brightness, battery detection, and sleep. Everything else works.

Any help is appreciated. It seems that this Chromebook is kind of special, given so many things work (probably because Dell sells the same device as a non-Chromebook, with Windows).

I will be happy to provide any logs, if anyone is interested.

I think in the case of drallion/whiskeylake, coolstar does just say to use rwl.

Okay, I guess I was wrong in saying that it was completely unsupported. However, CoolStar still doesn’t list drivers for your Chromebook on her website, so my advice would be to tag her on this post and/or ask her on the chrultrabook Discord server.

Hi @CoolStar will it be possible to make keyboard, touchpad, brightness, battery and sleep/suspend drivers for Chromebook SARIEN? Everything else seems to work.

For more details see Can I Install Windows in RW_Legacy mode? - #6 by archisman

I am happy to provide all the logs you may need.

Also, I will be happy to pay for these drivers, like other Chromebooks.
In case you live in the US, I will also be happy to temporarily send the device to you, if you need that to write the drivers.

I use this exact device on Debian Linux. Everything works fine including sleep keyboard and trackpad. You can run Windows in a virtual machine too. I think that that would be the best windows experience you can get on the device.

I think uefi is basically impossible to develop for it because it uses a different type of ec (so no ccd support) and its bios rom is difficult to access without soldering.

I tried Linux Mint, and everything worked very well.

Unfortunately I need Windows for using a scanner at my university, which comes with its own proprietary software. The scanner will not work with Virtualbox.

Don’t worry! On qemu-kvm you can pass through usb devices, or if its wireless, just pass through the wifi card itself.