Usb-c to HDMI output not working in ADL taeko

I have a Lenovo taeko running 4.20.4 latest firmware and primarily using latest debian on kernel 6.8.0-31. No matter what version of Linux and what kernel version I use I am unable to get a signal out of either USB-C port while connected to a working usb-c HDMI adapter. Xrandr shows two eDP ports numbered 1 and 2 but both are reporting as disabled and connected the adapter shows an error in dmesg.

Using this firmware version on my apollolake nasher board with the same operating systems and kernel versions, usb-c video output always works with little effort.

Nasher xrandr and inxi has the same output as taeko’s, bug the taeko won’t output a video signal through either port.

See HDMI through Thunderbolt 4 port not working on Redrix. I think your Chromebook has the same issue as Redrix, which has a workaround. I was on Wayland so if the workaround doesn’t work on X11 for u then try using Wayland.

This workaround requires using ectool, is this the ectool available under linux repos, or is this the ectool that is built from chromiumos source? Is there a simple way to get the chromiumos ectool binary without having access to a chromebook running chromiumos since all my chromebooks are running linux now, or is there guide directed at individuals to build rather than developers?

I’ve tried both X11 and Wayland and neither worked, but I can try each with the workaround to see if it helps once I can get a copy of the ectool binary . . .

You can download ectool at Artifacts · Dustin L. Howett / ectool · GitLab

Thanks for that, USB-c to hdmi is now working as long as the command is entered, just wish I knew why there’s a block between connecting a monitor and the command automatically initiating to better troubleshoot.