Success on UEFI firmware install on HP chromebook 14-SMB

Ok, so this was a steep learning curve with quite a few twists and turns. But it turned out great so far!

I got an out-of-support, 2017 Hp Chromebook 14-SMB for 30 bucks with a solid battery and pretty good cosmetics. I hated the chrome os and tried Crouton which bit the proverbial weenie.

Found mrchromebox and subsequently this forum, and set out to flash the firmware.

I got the machine to SeaBIOS boot to thumbdrives but when I went to flash the firmware in Chrome os, using the VT-2 terminal the machine errored after the first 2 lines and dmped the attempt. Apparently, this is an issue in some models.

So I reconnected the battery and powerwashed the machine and re enabled the seabios to boot from usb again and ran the firmware update script in a linux shell in Pop! OS from a usb and just like that, no error and i could flash the firmware to coreboot!

It testdrives great!

If anyone out there has this same chromebook model and they need help, I’m your hunchbach! Ive got the steps down for everything and I have the shortest routes for success. If I had another machine like the one i did, it would probably take about 2 hours total time to get the rabbit screen in coreboot. The FALCO board on this model works great!

Thanks to all who gave input and thanks to Mrchromebox!

The script is extensively tested on ChromeOS, it does seem strange that it would not work for you.

I found another individual with the same error. Its isdue #68. Mrchromebox said the same thing. The fix on that machine was to run the script in a linux shell.

MrChromebox actually said that it was user error. The fix is to download the correct file.

I didn’t dig that deeply. I just jumped back to what I read in the docs where it said that the script can be run in ChromeOS or in a linux shell. So I ran it in a linux shell and it worked. Maybe I could have dug more deeply to see the fix, but in my head, I wasn’t going to be using the native OS on the chromebook and I also like to know how things work in a broad sense, too.

But thanks for pointing that out! If I run into that problem again the hands-on approach of learning a new patch for a problem is good for me.

I got my machine up and running and experienced some of the problems that people were talking about with Ubuntu forcing snaps on people. One of the problems was Firefox 126.0-2 shutting down without giving an error log after an update. When I went to install Brave and Chromium, I found that they wouldn’t launch with the updated firefox. So I started over and reinstalled the OS and downloaded the other browsers then dumped firefox. I’m not a fan of them since they went to the dark side some years back.

I also had some trouble with Pop! OS not installing due to a minimum requirement of a 20Gig hard drive. My old Chrmbk has a 16 gig drive. So it stopped the install. All the other Os’s I played with on the list of supported Os’s had some buggy feels to them in the live install, too.

Basically, not many of the supported Os’s felt good or worked when I tried them. Pop and OpenSuse Tumbleweed were too big for the sdd. Endeavour was buggy on the live install. And Debian wanted to do an autoinstall without a live install and the gui looked like it was an accident. So I kind of gave up on the supported list for this machine. Maybe those will work on another. I don’t know. I could have worked longer on the problem. But I already had a working version of Ubuntu. So I went back to it and fixed what I knew would happen if I updated.

If someone was to do the same thing that I did on the same device or even another Chrmbk, I would advise that they do a minimal install of Ubuntu. Do an update of apt, then download Gnome tweaks to fix the problem with the right click not working on the mouse pad. Then download the alternative web browsers. Then dump firefox to avoid the crash scenario. And finally grab all the apps that you might want after fixing the hassles before they happened.

The only problem I have now is that my root file system runs out of space really fast. But the quick work around for that is to just download what I want to a thumb drive until I get a bigger ssd. Not bad for 30 bucks! But it’s only a temporary thing, anyway.

Thanks for the help! I really appreciate it!