Sleep issues after switching from Gnome -> KDE

System: Debian 12
Desktop Env: KDE
Kernel: 6.1.0-18-amd64
Graphics Platform: Wayland
Unique Softeware that might be relevant: I installed laptop-mode-tools to further optimize my chrultrabook and it might interact w/ sleep/hibernate functionality, IIRC, I installed it because sleep/hibernate was wonky already though

Here are some issues I come across:

  • The screen doesn’t go to sleep sometimes, it’ll just stare at me judgmentally
  • Closing the lid almost never puts the device to sleep

EDIT: Started digging into my settings to fully explain my setup to anyone that wants to offer assistance, and realized my /etc/systemd/logind.conf (use man logind.conf to get a breakdown of each of the options) is not configured correctly. It would be ironic if this months-long issue were that simple. I’ll tweak some settings and then update w/ my findings

FML. It appears to be working successfully now.

I’ve endured months of my laptop dying overnight due to not correctly configuring the logind.conf file. Perhaps it got reset when I deleted Gnome or something, very counter-intuitive defaults for a laptop. Glad to have it figured out though and not have to charge my laptop every time I want to use it

@macAttack was searching the forum with the same issue (ironically, i’ve switched from KDE to Gnome) and found this post. was wondering what config helped you. i’ve enabled HandleLidSwitch=suspend and it doesn’t seem to work.

FWIW, my laptop rarely drains the battery completely overnight, but something is off in that the screen will regularly wake itself up from sleep mode every 10-20 minutes
Here is my config:

Use man loginconf.d to better understand the options btw

1 Like

You gotta love them .conf files :laughing: glad you figured it out tho :grinning: