Pujjo Full UEFI Issues

I successfully flashed my pujjo board, but couldn’t get ubuntu to install without errors (after booting from live usb). Tried a variety of partition schemes for efi and root mounts but the installer kept throwing up errors like unable to read esp partition, grub install failed, and one time just crashed completely.

Some of the errors came up at the end of the install, and it looked like it had completed once or twice but the bootloader could never find an OS on restart. The bootlader would also hang on the white rabbit logo every reboot, usually for about 15 mins, before adding the ‘Esc… boot menu’’ text at the bottom for another 15 mins. Then either reboot, or load the shell.

Behaviour maybe points to a faulty emmc disk, though it’s only a week old. Is there anything I can do to diagnose?

What version of Ubuntu are you trying?

Ubuntu isn’t a recommended distribution, as mentioned in the docs, but if you’re trying anything older than 23.10, you’re more likely to run into issues given it is using kernel 6.2 while the lowest version supported is 6.4.

I would recommend trying out one of the other distros that are recommended and seeing if you get better results.

1 Like

I switched to 23.10 and it has installed without errors. However I can’t boot - I get the message Booting from ‘ubuntu’ device failed: verify it contains a 64-bit UEFI OS.

From the boot menu, it appears to be booting from <partition 1>/\EFI\ubuntu\shimx64.rfi although EFI\BOOT\BOOTX64.efi does exist. I can’t manually select it because selecting the partition in ‘boot from file’ just returns an empty window.

I tried booting back to live usb, mounting the efi partition and overwriting BOOT\BOOTX64.efi with ubuntu\grubx64.efi but then the ubuntu boot device disappeared completely.

Side note - during manual partitioning I noticed mmc…boot0 and boot1 partitions each about 4MB which I can’t seem to change. They don’t appear in gparted. Couldn’t find any documentation on these.

Ok this is weird. After a dozen or so attempts, it randomly booted into ubuntu once. Tried again and it hasn’t happened since.

Re-flashed firmware and installed endeavour os but still can’t boot (tried grub and systemd, also cleared nvram). Also having issue with the uefi firmware not loading (hanging on rabbit logo).

Not sure what else to try…

I have a feeling that the install media was bad, and may have imaged a messy install on the drive, but that’s just a hunch

did you back up your original firmware? see if you can get back to that, then reflash UEFI ROM?

Reinstalled firmware and have same issues. Even tried version 4.21.0.

Also, before disabling wp I tried chrx and dual boot with legacy firmware flash. But couldn’t get the second OS to boot.

Hmm…shot in the dark but have you tried testing the chromebook’s drive to see if it’s failing?