Pixelbook 2017 Eve, running latest Coreboot UEFI and Elementary OS 6.1 having TouchPad issues

Hi, I’ve got a Pixelbook 2017 eve, running the latest Coreboot UEFI Firmware and Elementary OS 6.1 alongside Linux Kernel 5.15.

TouchPad should be running the latest stock Firmware but I did just attempt to downgrade it via the MrChromebox Firmware Utility Script on Ubuntu 24. I’m assuming it didn’t work.

I’m having TouchPad issues on Elementary OS, it works but during boot if the user doesn’t interact with the mouse during login it’ll lock.

Seems to be using linput driver, I’ve tried to install and set Synaptics as the main driver for the mouse but no luck.

The mouse works using the default if the user interacts early on, so I’m assuming this is a issue with desktop environment.

The mouse also feels odd, double finger slide and tap for context menu doesn’t work well and is frustrating.

Any help is greatly appreciated, thank you.

That is a fairly old kernel. If you run the recommended audio script after install, and then reboot, does that put you on a newer kernel? If not, you may need to look up how to install the OEM kernel for Ubuntu derivatives, as 5.xx is far too old.

1 Like

Your right, I’m surprised I didn’t notice this.

It seems I’m also on a older version of Elementary OS, 7.1 currently is the latest based on Ubuntu 22.04 lts. For whatever reason elementary os requires the user to reinstall every major release…

So far I have most things such as audio and custom keys working via community made packages. (It’s from a Reddit user, I’ll reshare links here when I get a chance.)

I’m tempted to distro hop to a recommended distro like ultramarine for example, and then port over the pantheon desktop environment elementary os up keeps or find something similar.

Kay, looks like Ultramarine has Phanthen Desktop Environment prebaked as an image.

So I’ve distro hopped to that.

Trackpad works now, auto dimming for screen backlight is a little wonky, any tips?

I’ve noticed the top row of custom keys doesn’t work correctly, I know on Debian based distros this can be fixed with a package that configures the hot keys. Is there a similar fix for fedora based distros?

Audio isn’t working, what speakers does the Pixelbook eve 2017 have equipped, what drivers/install script should I use that won’t end up blowing them?

Finally, is swap space disabled by default on Fedora/Ultramarine? I don’t wanna burn out the flash storage.

It’s recommended to run the audio script and the keyboard remapping script for chromebooks after a distro install: Post Install | Chrultrabook Docs

1 Like

What about adaptive brightness issues for the displays backlight?

I’m now suddenly having the same trackpad problems on ultramarine… any suggestions?

Sorry, I haven’t personally run ultramarine. I’m currently trying to learn more about Docker etc to see if I can spin up a version of https://getaurora.dev so that it will work out of the box on Chromebooks.
All I can say is that, back when I had my Pixelbook, both the Fedora release at the time and Debian worked fine on it. I wonder if Debian 12+ with those scripts run would work fine on there? I don’t know if this could be a distro problem or a firmware problem.

1 Like

@jaiden might be able to help here

1 Like

Currently there’s still an issue with getting readings from the light sensor on Chromebooks, so I simply disabled auto adjusting brightness for the display backlight under Power settings.

I now manually adjust this via the FX Keys.

This is the last Chromebook related issue I’m facing, the trackpad works perfectly, however if the user doesn’t interact wirh it at initial login, it’ll be soft locked… is this an issue with the Phanthen Desktop Environment perhaps?

Also when it comes to tablet mode, screen orientation works flawlessly out of the box, any suggested on screen keyboards I could implement?

Thanks ya all, I appreciate the help.