MrChromebox Setup on CBx2 (Wyvern) - Disable Write Protect not working

I’m trying to install in UEFI Mode on my Promethean CBx2 Chromebox. I can’t get the write protect to disable. The device is listed in the “supported” list at MrChromebox.tech via CR50 or jumper.
I didn’t manage to find/activate the jumper tho.

Had one other model with a WP screw, that worked fine. Removing the Bios battery also didn’t disable WP.

Anyone can help me here?

the jumper is under the SSD, you have to remove it to access.

Mine looks like this:


Sorry for the little blurry photo. The soldering holes are not filled on my board. I tried different options to “connect” the pin-holes using paperclips, metal tweezers and such, but it doesn’t seem to have worked, as WP is still enabled… any better ideas how to connect em? The the electric line of these soldering holes should be the small golden circles around (but not in) the holes, which is legit for soldering, but makes connecting them a little harder.

Maybe also WHEN exactly does it need to be set/connected? Tried it turned on and turned off. During boot or something maybe?

as you noted, the connectivity is on the rings of the holes. A paperclip will work if large enough to make contact. Filling with solder and running a bit across to bridge them would be the most reliable way (and what I did on my JSL chromebook). This should be done with the device off and power disconnected (obviously).