Morphius: stylus rotation and keyboard disable in tablet mode under GNOME

Hi,
Has anyone figured out how to get the stylus input to rotate and the keyboard to disable in tablet mode under GNOME?
It seems that under Wayland this can only be fixed in Mutter, but that under Xorg there are some hacky ways to get styluses to use the wacom driver to then be able to force rotation.

Stylus works fine in default landscape rotation. Touchscreen input rotates but not stylus input.

1 Like

I haven’t had any issues getting rotation to work on the current coreboot, however yes I agree the stylus acts a bit odd in tablet mode. Currently running KDE with Fedora, are Gnome distros better for tablet support on this, would you say?

Rotation works fine for everything except the stylus, which is still mapped to the original rotation no matter the position.
Does KDE automatically disable the keyboard in tablet mode?

I’m not really sure if GNOME is better, I installed it because I’ve been using it for several years. Everything seems to be good except for what I’ve mentioned.

Looks like same stylus oddness in both KDE and Gnome, then. Wonder if we need an extra driver? I read that wacom drivers are in the kernel by default, so other than updating input-wacom as mentioned on their sire, idk what we could do.

Try the autorotate tool 22.04 - Touch sensor does not rotate after flipping the screen orientation - Ask Ubuntu

1 Like