Low FPS and no fan spin when gaming

I recently installed Arch on my Lenovo Chromebook IdeaPad Flex 5 13IML05 and for the most part the experience of getting Linux on the device was pretty painless. I sadly do have two major issues that have been causing some issues, both are related to the fan. The first one is surprisingly low FPS in something like Civilization 5, only reaching about 10 FPS on low settings. While it is doing this there is absolutely no sound of the fan spinning, so something is telling me that the iGPU isn’t running at full speed. The other issue is related to charging, where as soon as I connect a charger the fan seems to spin up to the max. (And no, before you ask, playing the game while the charger is plugged in does not fix the issue). Does anyone know what might be causing this?

Check the actual GPU utilization. One way of seeing it is by using Mission Center. If it is at 100% then maybe turn on the fans manually using ectool or the Chrultrabook Controller app.

Just to check and make sure the docs were followed, did you also run through the audio and keymapper scripts after installation?
You aren’t using a zen kernel, correct?
Link to docs:

Link to audio patch:

Link to key-remapper script:

I have used both the audio patch and key-remapper, both did a good job at what they set out to do but did not fix the issue. I am also using the mainline kernel.

It is close 100%. Maybe this is literally everything I can get out of the iGPU. I will have a look at the Chrultrabook Controller app.

Seems like the controller doesn’t even see the CPU temp sensor. Psensor does see them. In addition to that, fanspeed is also set at 0%.

I have jinlon with i3-10110U and I get 40-50fps@1024x768 in Civ5 on Fedora 39 so maybe it’s GPU driver issue in your case.

Regarding fan and fan curve setting, I have the same problem. Auto fan control is setting both fans to 0 regardless of cpu temp. Custom fan curve setting is also not working.

ectool temps all gives this output:

--sensor name -------- temperature -------- fan speed --
Charger               317 K (= 44 C)          42%
5v Reg                322 K (= 49 C)          96%
CPU                   337 K (= 64 C)          -1%
IR Sensor             310 K (= 37 C)          -1%

meanwhile sensors gives this:

Adapter: ISA adapter
Package id 0:  +77.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +76.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +77.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: Virtual device
temp1:        +64.0°C  

Something is definitely wrong with fan control and temp reading in EC

I am playing at 1080p so that might be it?

I doubt it. Just checked at 1080p i got roughly the same framerate.

I also set automatic fan curves using this post.

It’s weird tho that for two of my sensors (CPU, IR) all values were 0.

Try turning on the fans manually and see if your gaming performance is better.

Tried running them from the Chrultrabook tools but it seems to have no effect on the fans. I’ll see if I can work it some other way.

Try using the ectool CLI

Cannot seem to build coreboot-utils. Getting:

me_status.c:4:10: fatal error: commonlib/bsd/helpers.h: No such file or directory

What fan controller should I use?

Just run ectool fanduty 100 to put fans to 100% and ectool fanduty autofanctrl to set fans to automatically spin based on heat and stuff.

Ectool wasn’t installed. Installed it and now it works just fine. The FPS is still low but I think that’s just the lower frequency of the iGPU.