Lenovo yoga 11e (ultima) eMMC issue

no matter what distro or how i try to install i always get this message somewhere during the installation period:
(windows works fine btw and i’ve confirmed for a fact the drive is not faulty)

[  333.434809] mmc1: sdhci: ============ SDHCI REGISTER DUMP ===========
[  333.434814] mmc1: sdhci: Sys addr:  0x00000400 | Version:  0x00001002
[  333.434820] mmc1: sdhci: Blk size:  0x00007200 | Blk cnt:  0x00000400
[  333.434824] mmc1: sdhci: Argument:  0x00c415d0 | Trn mode: 0x0000002b
[  333.434829] mmc1: sdhci: Present:   0x1fff0106 | Host ctl: 0x00000012
[  333.434833] mmc1: sdhci: Power:     0x0000000b | Blk gap:  0x00000080
[  333.434837] mmc1: sdhci: Wake-up:   0x00000000 | Clock:    0x0000fa07
[  333.434841] mmc1: sdhci: Timeout:   0x00000006 | Int stat: 0x00000000
[  333.434845] mmc1: sdhci: Int enab:  0x03ff000b | Sig enab: 0x03ff000b
[  333.434850] mmc1: sdhci: ACmd stat: 0x00000000 | Slot int: 0x00000000
[  333.434854] mmc1: sdhci: Caps:      0x446cc8b2 | Caps_1:   0x00000807
[  333.434858] mmc1: sdhci: Cmd:       0x0000193a | Max curr: 0x00000000
[  333.434862] mmc1: sdhci: Resp[0]:   0x00000900 | Resp[1]:  0x36470142
[  333.434866] mmc1: sdhci: Resp[2]:   0x53445731 | Resp[3]:  0x00000900
[  333.434870] mmc1: sdhci: Host ctl2: 0x00000000
[  333.434873] mmc1: sdhci: ADMA Err:  0x00000001 | ADMA Ptr: 0x1ffff200
[  333.434876] mmc1: sdhci: ============================================

I think galliumos had some patches for that. No clue if this is the one needed or if it even still works.

tried galliumos, and no luck

I also have an ultima and Gallium worked for me but that was quite a long time ago, and i don’t use it anymore cause it’s old.

Hi there! were you able to get it working? Same issue as you and same device, tried several distros already but when copying files it locks up. Tried installing windows and that works. Really need to get this working for my child’s upcoming school activity. Thanks!