Lenovo Yoga 11e Chromebook UEFI Linux sound freezes on videos

Hello,

I recently converted a Yoga 11e Chromebook to support other OSes for fun. Everything almost works (some distros don’t install correctly like Ubuntu) but, with every Linux flavor I try (ex. Xubuntu, Lubuntu) I run on a consistent issue. When I try to see videos on YouTube after around 5 minutes tops, the sound freezes on a high-pitched note and the video keeps buffering nonstop. I tried to lower the resolution but no luck. The only distro that works 100% is GalliumOS but it’s ancient and I have security concerns.

did you run the audio scripts? they do some things that may have a huge impact

1 Like

No, I didn’t try it. Was there an after-installation manual? I will try and see if it fixes the issue. Thank you!!!

You will probably need to enable vaapi to get smooth video playback.

Vaapi is installed by default on debian/(x)ubuntu, but has to be enabled in firefox by going to about:config and changing media.ffmpeg.vaapi.enabled to true

You can check if its using vaapi by running firefox from a terminal and playing a video. If its using the vaapi you will see something like in the output:

libva info: VA-API version 1.17.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_17
libva info: va_openDriver() returns 0

Regardless of audio issues doing this is a good idea for battery life.

1 Like

Yes, see here Installing Linux | Chrultrabook Docs

I also recommend getting the chromebook shortcut keys working with this script:

1 Like

I know this is a bit off-topic but what distro are you running? I have the same laptop but couldn’t get anything else to work but gallium. Others just wouldn’t install properly.

The only ones working are Gallium (which is old but I think someone picked it up again), Ubuntu flavors (but have the aforementioned issue with videos), and ZorinOS but no keyboard or Brunch but it only installs the last supported version of ChromeOS. s31bz gave a guidebook in earlier reply which also lists compatible OS with fixes.

Fedora should work just fine as well