Lenovo ThinkPad C13 Yoga Chromebook Enterprise Delete?

I’m just saying that if you’re having difficulties with getting shimmer to work, I imagine there could be other avenues of getting support.

It took me all of two seconds to find that they have a Discord server as well as a Fediverse instance.

Except that does not seem to be what you’re doing. Seemingly nothing is preventing you from using it as a Chromebook. I’m not entirely sure how enterprise management works, but the fact that you could login with your personal Google account makes me think that the restrictions weren’t that restrictive in the first place. In any case it sounds like whatever you have done so far in terms of sh1mmer has worked, if the below paragraph is any indication.

If you’re not intending to replace the stock firmware with MrChromebox’s UEFI firmware, then I think I’ve done all that I can to help.

I am not familiar with these sites, and the one or two times I was on a Discord server was un-nerving. Lots of nasty posts and animosity. Scary.

My strategy here was quite simple. Try to get this Chromebook off on Enterprise Enrollment using whatever means worked.

Failing getting this box to be a standard Chromebook, I’ll try to replace the stock firmware with MrChromebox’s UEFI firmware and install Windows 11 (?), as I’m not familiar with Linux.

My last position is to remove the smallish M.2 Drive (which I’ve already had out) and recycle the rest.

I’d hate to recycle a Box with only 8 operating hours on it. Just seems wasteful. I’m surprised doing an Enterprise Delete on a Chromebook isn’t common.

Thanks for the assist.

The Fediverse is a wonderful social media place by humans for humans, not owned by a corporate entity. Here is their corner of that network: Akkoma
Discord server:
Utada Hikaru Fans
I’m of the opinion that Linux, being far less resource-intensive than WIndows, would work better on this hardware. If you go the Windows route, here’s some docs for that:
Installing Windows | Chrultrabook Docs

Thank you for the info. I’ll go take a (cautious) look at those links.

One of the things that made this Chromebook attractive was going to be the learning experience I’d get with my first attempt at ChromeOS, and to some degree Linux. To keep this Box on ChromeOS still is my focus, even if it’s waning at times. Windows seems much more resource intensive ChromeOS (even if this Box exceeds the minimum requirement for it).

My present 15 inch laptop is getting old, and even though it still functions well (except battery life), it doesn’t meet the requirements for Windows 11. I typically don’t run many applications on it, and I thought switching to a smaller Chromebook with primarily web based Apps could be fun. I typically take it with me when I travel about. I have a very powerful Main PC here at home.

I wish removing this Chromebook from Enterprise Enrollment was as easy as others boxes that I’ve read about. Some just have to disconnect the battery, others remove a screw, and still others have to put a jumper between two points on the Motherboard. I’ve tried using the Debug Cable but so far no joy with that method.

I need more details on where this would be / how to do it on this box. Please.

Thanks to all who have chimed in and tried to help so far.

Requirements can be bypassed btw.

My understanding is the Ryzen™ 5 3500C. along with 8 Gigs of DDR4-3200, and a TPM Chip meets or exceeds Windows 11 requirements.

I know you can bypass same (it’s easy using Rufus 4.3) but if I go in this direction I’d rather not have updating issues with Windows later. :wink:

I don’t think bypassing TPM requirements is going to cause Windows to break in the future. Literally everyone who has Windows on their Chromebook has to bypass TPM requirements. But you can always install Linux to replace Windows 10 :penguin:.

I know that’s a common thought but I’d rather know Microsoft won’t stop updates if I have the required hardware.

However, if my existing Laptop is still running close to October 2025 (when Windows 10 is going to be unsupported) I’ll install Windows 11 using an image I already made using Rufus on a USB Stick just for that purpose.

I’m trying to make (IMHO) a big leap to using ChomeOS on this Chromebook. And I like what I saw so far in my limited look yesterday. Jumping to Linux may take me quite a while to get my head around.

Oh my there’s a tremendous mount to filter through on those Sites.

One of the first things I came across is

An unenrollment exploit released on March 9th, 2024, that works for ANY BOARD (with a leaked RMA shim) running ChromeOS v119 and lower! Made by @electronis.

For users on v120 or newer: You MUST downgrade to v119 or lower (ideally v112) in order to use CryptoSmite. Ignore this section if you’re on v119 or lower already.

Enter Recovery Mode and press the TAB key, then check the number at the end of kernver=. Reference images can be found here: ⁠me-muero⁠

If it ends with a 3, you will NOT be able to downgrade and your only option is to use ⁠pencil-bypass (which isn’t recommended).

If it ends with a 2, you WILL be able to downgrade to v119 or lower. Follow the instructions here on how to downgrade: ⁠talk⁠

Download a SH1MMER Legacy Prebuilt image here: dl.osu.bio

Disable OS verification (blocked or not, doesn’t matter), and boot into the Legacy shim.

Press the S key to start CryptoSmite and input this decryption key:

Type in Y then press enter, and it’ll automatically reboot upon completion.

Proceed through the setup partially till you get to the Add Account Screen.
If you get an update screen, please reboot and then press CTRL + ALT + E on the Wi-Fi screen, which allows skipping or makes the update not appear at all.

Powerwash the Chromebook after getting to the “Add Account” screen. Once it boots back up, it’ll be fully unenrolled."

I have no idea if this works or even if it will “brick” the Box.

I posted this just to show a small sample of what’s on those sites. This example was on a Discord Site.

Hi Team,

There’s been a positive (?) twist to the saga.

Feeling I was doomed to failure on my last effort above, I spent 4 hours looking last night for a next step, and came across the newest CryptoSmite on a Discord (OMG!) Server.

CryptoSmite =>

CryptoSmite is an unenrollment exploit for v119 and lower. It works on any board and works just like any other unenrollment exploit.

If you want to know how to use CryptoSmite, please follow these instructions:

Download a CryptoSmite shim “here” and flash it.

Disable OS Verification and boot into the shim. => Jim’s note - Hold Esc + Refresh, and then hit the Power button.

Run this command first: cryptosmite.sh and let it finish.

Run this command after: tar -xvf /mnt/shim_stateful/stateful.tar.xz -C /mnt/stateful and let it finish.

Run exit and it should automatically reboot into verified mode and unenroll.

Doesn’t Work!

Follow these instructions then, since CryptoSmite doesn’t seem to work for some people:

Downgrade to v112 and try again.

So I found the site and downloaded a modified cryptosmite_zork.zip and the latest Zork Shim Pre Built for use in CryptoSmite from March 9th 2024. I also pulled down the 18 gigs of CryptoSmite stuff in one big Zip file just in case. It contains the modified Shim files for every baseboard -Motherboard to Windows folks- along with the CryptoSmite executable (Windows or Linux? Probably the later if I remember correctly) to make your own modified CryptoSmite Bin files. ChomeOS can run these Bin files to “flash” or reimage the “bios” and ChromeOS starting details.

Supposedly running a CryptoSmite Bin will remove Enterprise Enrollment without any other remedies like battery disconnect, jumpers, screw removal, etc.

So this morning (yes I’m a glutton for punishment at times) while drinking my coffee I decided I needed to face the music, and pick Return to Secure Mode, so I could see what version of ChomeOS is on the Box when I sign in.

It followed the previous pattern for Enterprise Enrollment but when I tried to sign in with my Google Account it wouldn’t proceed which was scary. It said it didn’t recognize that info and made my try again. I tried again, and again => fearing that my last effort in my post above had “Bricked” the Box and I was gong to be in a world of hurt. After the 3rd attempt it moved me to a screen to sign in as an individual (in my haste to find out what version was now on this Box I didn’t take a photo of that screen - even though I’d never seen it before).

So I clicked to sign in as an individual, and it accepted my Google info, and booted to the Home Screen but it advised it was applying an update.

I immediately checked the version and it was current (Version 122) which meant I’d have to “downgrade” below version 120 (ideally v112 according to the CryptoSmite instructions). Well I knew this could happen, but I wasn’t happy about it. In anticipation of this I already downloaded the version 112 Zork bin during my marathon last night.

Just for grins, I shut down the box. Then I powered it up but there was no sign of being managed by Telecom.com or any Enterprise Enrollment! What? :confused:
So I shut it down again, and rebooted. Same thing. Then I tried just a Reboot -same thing. I went on line and found a couple ways to check for Enterprise Enrollment and there is no evidence I can find that this Box is still being managed. I then tried opening Files from a USB Drive, playing tunes, looking at photos, etc., => no problems. I surfed the web looked at Gmail, Hotmail, Corvettes, etc. all just fine. I transferred a couple of FLAC Tunes and some other data to the internal hard drive without issue. (I can’t put a lot as it’s “only” a 256 Gig M.2 SSD from Western Digital).

I don’t know what other tests to do but I’m calling this a success! :wink:

What do you think?

You didn’t need to post this here. In fact you might consider removing it, as bypassing enrollment is not condoned or encouraged for obvious reasons. Projects that bypass enrollment benefit from being as under the radar as possible.

I’m glad it worked out for you, anyway. Enjoy your (almost) brand-spanking new Chromebook.

Again, as I stated above, I don’t want to break any rules here. (If a Mod or Admin thinks my posts need editing, please do so. I will not be offended.)

I posted the instructions for CryptoSmite above so any members would not have to go through the 20 or 30+ hours of effort I did (never mind buying the Debug Cable off eBay as picking that up took another 4 hours). Even though I didn’t have to try CryptoSmite it seems to be the simplest of solutions => if it works f course!

Now I just need to learn how to work with a Chromebook. (Links, Books, etc., Please.)

I hope this is helpful.

Chromebooks and ChromeOS are meant to be easy to use. You shouldn’t need a link or book to use it lol. Just sign in with your Google account, and do Ctrl + T to open Chrome. Done.

I took this project on as an educational challenge, and so far it certainly has been one.

I’d rather not poke around to figure out how ChromeOS functions. I’ve been able to pull down a couple of Chromebook Mags from last year for reference. At least they will help me get started.

Well once you unenroll the device, if you intend on running Linux or Windows, the docs associated with these forums will be able to help you replace the firmware around then:

Thanks for the heads up. :wink:

1 Like