Lenovo 300e 3rd gen.: After linux install and reboot -> UEFI shell


I installed UEFI (Full ROM) Firmware via MrChromebox firmware-utils.sh on my Lenovo 300e 3rd Generation (VILBOZ360-ZHKO)
These are my steps:

  • put the device into Developer Mode

  • disable firmware write protection by removing the battery and run via usb-c cable

  • flash MrChromebox’s UEFI Full ROM firmware: Fx Ver: MrChromebox-4.22.2 (01/20/2024) Device said Lenovo 100e Chromebook Gen 3 while I am on 300e.

  • boot ventoy USB and choose an iso. I’m using Manjaro gnome here but also tried xcfs and sway.

On reboot the boot process hangs on the following errors (constant flow of this error):
SQUASFS error: Failed to read block 0x1b527979: -5
and at one point I end up in UEFI Interactive Shell
with map: No mapping found

What am I missing?

my partition table GPT/UEFI:
mmcblk0p1 EFI 1G /boot/efi
mmcblk0p1 SWAP 4G
mmcblk0p1 ROOT 10G /
mmcblk0p1 HOME …the rest /home

Your device does not support booting from the internal emmc due to a missing driver.

Hello. I found myself in the same exact situation with the same device. I used a MicroSD card for a bit and was fine with that until it suddenly stopped working and Coreboot no longer recognised it either. I then tried to install the RW_LEGACY FW, which did let me attempt to boot a proper Linux distro from a Ventoy drive but it always ended up failing. (boot loop, hung on black screen, etc…) So I’m wondering if there is a step-by-step guide on how to install SeaBIOS instead. I didn’t find it on the mrchromebox.tech website and I don’t want to try risking experimenting too much and bricking my device. (I am a noob, so yeah…) I do have a Suzy-Q cable and the ability to open the device and unplug the battery.