Intel SOF Audio Driver 1.0.4 not working on SPIN713

Hello,

I have problems with installing the Intel SOF Audio Driver.

The audio icon is visible for about 5 seconds after starting before being disabled.

Any ideas?

The error message is:

This device cannot start. (Code 10)

{Device Timeout}
The specified I/O operation on %hs was not completed before the time-out period expired.

hi i have had the same problem before but i have found a fix. when in the intel sof folder once downloaded you will see a folder named ‘gui’ in the folder you will see GenLicence application and you will have to click it and click allow when asking. Once its open click on generate unsigned license and save the file on your desktop (or anywhere if you want). once youve done that click on open licence portal and it will take you to coolstar license manager where you have downloaded the driver. Login and go to purchased licenses and click on the coolstar sof audio driver that you gave brought. upon opening you will see title called register licence and under it a subtitle saying unsigned license file. next to it click on choose file and select the unsigned licensed file that you saved on desktop or wherever you saved it, then write the device name of your chromebook (can find in settings /system/about) then scroll down and you will see a button that says submit. After clicking that a file should be downloading called “sof_signedlicence.bin” once downloaded in the application gen license click on select signed license select the “sof_signedlicence.bin” then a message should appear saying " license succesfully installed reboot to activate" click ok then reinstall the sof audio driver and it should be working :slight_smile:

1 Like

Hi, I was having the same problem, but when opening the GenLicense on the gui folder from the downloaded SOF Audio driver it generates the unsigned license as inteltcss-unsignedlicense, not as sof_unsignedlicense.
It then gives me an error when submitting on the coolstar purchased licenses as Invalid/incorrect product type.

doing the reinstallation in this specific order did the trick.

thanks!