I think I bricked my C13 Yoga chromebook

I’m not sure exactly how I did it, but I ended up in a situation where my new-old-stock (basically fresh out-of-box) C13 Yoga won’t boot. The symptoms are:

  • Power button flashes a few times (sometimes 6 times with a pause then once, sometimes three times, sometimes just once). I’ve been looking for a troubleshooting guide to interpret the flashes to no avail.
  • An external monitor hooked up to the HDMI port will see valid signal for a bit less than a second, then nothing, then signal several times just after power is applied or the power button is pressed
  • The above symptoms are present when the battery is installed and removed

The steps I took to get myself into this jam are:

  • Booted into developer mode
  • Disconnected the battery
  • Used the VT-2 terminal
  • Ran the MrChromebook utility script to install “Full ROM”
  • Saved a backup ROM
  • Enabled trackpad
  • Requested shut-down
  • Plugged the battery in
  • Tried to boot (problems arose)

My suspicion is that I might have interrupted an initial boot process after the ROM was updated, and now I’m in trouble?

Any advice is welcome. I have a pretty well-stocked electronics lab, so I could probably execute a de-bricking if necessary, but I’ll likely need to buy a SuzyQ cable (can you still get these?) or a flash programmer adapter, so I hope I don’t need to.

Thanks!!
Willow

I have the same machine. I bought two of them after hearing a 37C3 talk about this project. My long-term goal is to have one be a warm spare for the other.

You’ll want to use Morphius as a keyword for your searches for related information. That’s the Chrome OS code name for the board these machines are based on.

On the first machine, I went the RW_LEGACY route, and had lots of black-screen problems until I started using iommu=pt as a boot parameter. I installed Pop!_OS because it sounded like others had good results with it on this machine, and have been using it regularly since with just a few annoyances.

I would prefer to run Debian, and just in the past week or so did a full UEFI firmware replacement on the second machine. I thought I had bricked it at one point. In the chrultrabook docs on OS installation, there is a step that the author says might take a minute or a few minutes, and I think mine instead took 10-15 minutes. I don’t know what was going on, and I’m mostly not interested in reproducing it.

It worked out, and I can get the coreboot firmware to boot the machine using an OS on a USB drive. Current status is me trying to figure out how to make the standard Debian 12 installer use a different version of GRUB than it currently does, because as someone here discovered, the version in use is incompatible with this firmware.

I don’t think I saw the power LED codes (these are POST, no?) you describe, but I did search the web for power-on testing and such on this hardware, and turned up dry.

I hope someone else can provide helpful advice. Mine is just to boot it and then give it more time than you think it needs before considering it dead.

I’m anxious to hear how yours turns out.

You know, I wonder if I’m boneheaded enough that I missed something important re. coreboot. You said “I can get coreboot to boot from a USB drive”. Is that coreboot booting an OS on a USB drive, or coreboot itself is on a USB drive? I haven’t installed coreboot; as I assumed it was part of the flashing process.

ooOooh! Progress!!! I held-down escape and reload while pressing the power button (with the battery disconnected) and it booted into the UFI shell! :dancer::dancer:

I had a Manjaro ISO (on a USB drive) at the ready, and it booted into the live CD!

Ah, yeah, I phrased that poorly.

Fixed!

1 Like

I now have the same symptoms where after the first install I think I interrupted the first POST accidentally by pressing power (I thought I asked for shutdown instead of reboot when the post took longer than I expected) and now the power button only blinks and the fan spins for half a second (I can hear the click sound).
I will try if this works for me.

If it doesn’t does anyone have any idea if we can use a Suzy-Q cable to un brick my situation?

Update: holding escape and reload while powering doesn’t help :frowning:

Is there a discord server that I could use to talk to people to get help?

Update2:
You need to plug in the battery as well when performing the esc + reload method.
I am not sure why this is happening or what the flashing lights mean but I at least now have a bootable laptop!

1 Like

esc + reload method really saved me here thanks!!!