HP chromebook 14-smb FALCO and Ubuntu 24.04

Hey there, folks. I’ve got an ($30) HP chromebook 14-SMB with a celeron processor and a FALCO board that I’m getting ready to try and flash the firmware on to UFEI and I’ve done some pretty extensive studying as to how to go about it. I’ve looked into this subject for a solid week. Lots to digest, though most of it is old info and fragmented. But then I found Mrchromebook and the Chrultrabook project and it filled in the missing pieces, but I’m still not 100% for if I should make this jump.

I can boot to Ubuntu 20.04 through 24.04 can boot from USB in the SeaBIOS and all run GREAT on a USB flash drive. But the earlier versions like Xfce ubuntu 16.04 didn’t run so good and under Crouton, it was limited at best. The recent USB live sessions were awesome. In fact, I’m surfing with firefox on a live install, right now as I type this because Chrome on this chromebook isn’t a supported browser for the Chrultrabook forum! Go figure.

With this live USB install, I have great keyboard response, clear graphics, not obviously buggy and it’s generally just like my last install of 22.04 that I did on a laptop from the stoneage, (but it got swiped!) only even better, though from a USB drive! But before I jump in, I want to know if there are any specific issues I should be looking at regarding doing this install.

First, I’ve done all the research that I can find on this subject of wiping the ChromeOS, dating back to 8 years ago and doing a dual boot (which I want to avoid). Second, studied mrchromebook’s site and then I watched the recent video from Veronica Explains on youtube, found here:

This video is from only 2 months ago and she lays it out, really well, step by step for everything from flashing the firmware to installing a couple different distros and debugging one of them.

My machine is in developer mode and I’ve done all the poking around to find the board name, CPU model name and all I need to know to cross reference on chrultrabook and Mrchromebox. It all seems to fit into the parameters for doing a linux install under the UFEI firmware, too. The board is EOL, but the sites say that UFEI is supported on that board.

The machine works so well on ubuntu 24.04 via the flash drive that I’m totally tempted to do this, but I’m scared that I’m missing something that could be detrimental. I guess I don’t see how a USB live session acting so great would lead to a bad permanent installation on the SDD.

I note that on that video above, Veronica had a problem with boot loop and a conflict between Grub 2.06 and 2.12 when she did a Debian install and I looked to see if the two Grubs for the ubuntu distros I want to run were different - and they were. Ubuntu 22.04 runs Grub 2.06 and 24.04 runs Grub 2.12.

I’ve only got one computer to play with and no back up computers. I can’t stand the ChromeOS and having to log in to use apps and save things on the cloud and I really want to load linux on this machine after test driving it and being a pretty long time ubuntu user. Both ubuntu 22.04 and 24.04 use the post 6.4 kernel, too. Which is required from what I’ve seen.

Is there anyone out there who has done a UFEI firmware flash and installed Ubuntu without problems? I’m not a complete noob. But I don’t have super kung-fu, either. I know enough to get me into trouble, sometimes. And when it comes to this one, since the sites are saying that ubuntu is not supported, it’s got me wary. But ubuntu 22 and 24 are both up to date with the supported Kernels for the UFEI firmware (ubuntu 20 is running a 5.15 kernel) and that Grub loader on 24 is a 2.12 version. So it looks like much of what is required is there to do an install of Ubuntu 24.04. But the lack of support and the warnings that some things might not work have me thinking. And again, everything works fine on the USB live session! Sound works, USB works, though I haven’t tested HDMI, nor do I need it. The software all loads and the overall feel is that this is solid when it’s running from a live session on a USB stick.

I just can’t see anything obvious that I should be wary of by using the Grub 2.12 boot loader and Ubuntu 24 after a UFEI firmware update.

Any insight before I flash this firmware would be great. I guess I can do the UFEI flash and if a full install fails, I can then boot from a USB stick and download another distro to install, but man, this version of Ubuntu is SLICK and it’s running great from a USB stick! If it’s not running on some machines, I want to know why. And if someone has had success, even on another device, I still want to know which model and if there are known issues. I can’t be the first guy to be wanting to do this install on this model of a Chromebook, can I?

Sorry this is so long, but after a week or so of hacking on this machine and getting all the info that I think I need, if I didn’t lay it all out, here for someone who’s ahead of me on this kind of thing, I’d be cutting the community short for info.

Any insight for me making this leap would be great. It all looks good on my end. But if there is someone else who has a Chromebook 14-SMB that they’ve installed Ubuntu on, I want to know if they were successful or if they had pitfalls and how to avoid/fix them.

Thanks for reading this.

Scot

Yes, a lot of info out there is likely outdated.

GalliumOS is dead, chrx is dead, SeaBIOS for your Chromebook is also dead (especially if you’re using John Lewis’s). Use what you want obviously, but MrChromebox’s full UEFI firmware is what’s supported for your device right now.

The site says Ubuntu is not supported because it’s not supported by the chrultrabook project. That only means that feel free to insist on using it, but it’s not necessarily tested or guaranteed to work because the people working on the project don’t want to support Ubuntu.

You mentioned this being your only device. Flashing firmware inherently carries a risk of bricking, so just want to make sure you understand the consequences of a potential bad flash.

1 Like

Thanks for the reply. And I’ve been eyeball deep in the warnings about flashing the firmware. That’s partially why I’m wary. I can get another machine, I’m sure. And it appears by the list of information from mrchromebox, that my processor and board are supported by that flash.

Can you tell me why ubuntu isn’t supported by the Chrultrabook project? It’s been a solid distro for me for many years. There are a few hangup’s like with all distros, but it runs really well on a ton of old hardware. And many people have already used the older distros on Chromebooks, too, though I don’t see many who flashed the firmware with mrchromebox’s flash script. There was one or two I saw who did it with John Lewis’s firmware. If I don’t flash the firmware, and then install a distro, does it wipe the ability to boot into SeaBios?

Any insight would be greatly appreciated. Thanks again for the reply.

Scot

I can’t comment on their behalf, but Ubuntu isn’t universally loved as a distro by the Linux community, nor is Canonical universally loved as a company.

The warnings plastered all over the docs do err on the side of caution. You’ll probably have no problems at all, but it’s important to make sure people who do flash the firmware are well-informed.

Right now you’re using Google’s firmware + the SeaBIOS payload (pressing Ctrl+L on the developer mode screen boots the payload). If you were to flash MrChromebox’s full UEFI firmware, it will overwrite the entire firmware (Google’s firmware and SeaBIOS together), hence why you would need to first disable hardware write protect (screw probably in this case) and why it carries a risk of bricking, as if the firmware fails to load when starting up, then well…

You will be prompted by MrChromebox’s firmware utility script to first backup a copy of your existing firmware (so Google + SeaBIOS), so that you can always reflash that firmware.

And that’s where I am. I’m actually checking to see if there are any hang ups that I should avoid that I may have missed. I’m about ready to pull out the screw, very shortly. Then flash the firmware.

I do have a question, though. If I remove the battery or unplug it, does it send the machine back to factory settings without ability to go into developer mode and into VT-2 terminal as chronos? Or is that just a risk I take once I pull the battery out and take out the write protect screw?

Thanks again. I’ll be ready to make my choice as to what to do when I hear back! Hoping that’s soon! I have a ton of things to do on the computer and I cannot, I repeat CANNOT stand the cloud based system with a forced google login to do any work.

~Give me open source or give me open sores.

I also just found this:

So as of right now, the kernel update is clean on ubuntu for the UFEI coreboot firmware, or so it would seem.

I sincerely don’t see any obvious hangups, other than the problem with the 2.06 GRUB loader.

Void Linux runs fine on Falco. GRUB is version 2.12.1 – I have had no problems. Void Linux has a live image with a desktop (Xfce) that you can play with.

Ubuntu may take too much space on the built in LITEONIT LSS-16L to allow you to add much additional software or user files.

image

1 Like

I’m having trouble getting the script to work. I’m booted to a thumb drive with Pop! OS on it and it works great. I’m on battery power, now. But I need to know if I need the battery disconnected before I try the firmware update again. I had the battery disconnected and the machine was on AC power and I tried the firmware script but ran into this same error.

Then I powerwashed the thing and re-enabled legacy boot and SeaBios. She’s got the WP screw removed, right now.

I keep getting closer, then I run into snags.

Any help would be greatly appreciated.

Scot

I seem to recall that Falco would reprogram the flash without the internal battery - on AC power.

I don’t know why you are seeing the syntax error, though.

Thanks for the speedy reply and thanks for the info.

Does the battery NEED to be disconnected to flash the firmware with mrchromebox’s UEFI firmware install script? Or is it Okay for one to try doing the firmware script with the battery power on?

Thanks in advance,

Scot

Some models need the battery disconnected but not Falco. Just remove the WP screw should be all you need.

1 Like

Thank you. The screw is out and I’m ready to give it a whirl, tomorrow. Are there any other pointers you might suggest before I jump into this?

Thanks again for the speedy reply. I really hope this works. I like these little machines, so far. And I love linux. So if I can get cheap laptops that are EOL and build them to boot to linux, I’m as happy as a clam in brand new sand!

I tried the firmware script but ran into this same error

Screenshots would be helpful.

In recent years they have been consistently breaking packages and other stuff, both intentional and by accident, which consistently resulted in people crying for help.

Additionally they have started to force snaps down peoples throats even if they used the apt command line to install a package.

Last Straw for us was that they kepts EoL Kernel versions for extended periods of time and have now released an LTS release containing a non-LTS kernel.

1 Like

Well, i installed pop os on the machine and the install crashed. So i tried ubuntu 22.04 and it worked after i did a minimal install.

At furst, with the full install of Ubuntu it crashed during the install. But after the minimal install it worked great. It runs stable and there are minor issues with easy fixes. Like the right click on the mousepad didnt work at all. But i installed gnome tweaks and flipped a switch and it worked fine.

I couldnt see a minimal install for pop. I think its already chopped down pretty small and about half the size of the full install of ubintu 22.04 LTS.

Works great.

You do realise Pop!_OS is also based on Ubuntu right?

And what is the reason to use 22.04 over 24.04? Is this some weird Windows parallel where people want to use some exact old version of Windows 10?