HP Chromebook 11a g6 ee can't boot into any linux distro

Hi there!
After installing the UEFI firmware on my HP Chromebook 11a g6 ee (snappy), I tried booting into multiple distros like lubuntu and arch, but I’m getting the same error messages every time I try boot into the distro. These error messages prevent me from fully booting into the distro.

My error messages were:

[2.045207] simple-framebuffer simple-framebuffer.0: Unable to acquire apertu
[4.451555] i915 0000:00:02.0: [drm] ERROR Failed to probe lspon

I don’t know what these error messages mean and I tried searching them up, but I got nowhere. I have done this before and it worked for another chromebook.

Did I do something wrong? How can I fix it? Any help would be greatly appreciated.

I’d say Arch, Fedora and Debian would be better supported here than Ubuntu distros. Those error messages are stopping you from booting the distros?
May we have you send a short video of the boot-up to see if possibly anything else could be failing?