HP Active Pen on Jinlon?

Has anyone here gotten the HP Active Pen working on linux (Ubuntu 24.04) on Jinlon?

With a vanilla install, the “Tablet” section of gnome-settings shows no tablet, so I think it’s a matter of correctly detecting the hardware via libinput?

The screen works great as a touchscreen, just not as a tablet with the pen.


Ubuntu isn’t supported, behavior like that can be expected

I’ve tried Debian 12 and gotten the same thing. I’m trying Ubuntu 24 now because it has the latest kernels (newer than Debian 13).

I’m not sure what “supported” means in this context. Are you saying that other distros have working wacom support for this device?

“not supported” means that if you have a problem and ur on Ubuntu then the people answering your question will say “Install something else”. If u have a problem with audio not working, WeirdTreeThing will not help u unless it’s on a “supported” distro.

Honestly, I just want to know if any distros support the screen behaving as a wacom tablet with a USI pen. If anyone has a working setup, please let me know which distro and setup scripts you’ve been using.

Idk. I use a Jinlon daily but don’t have a USI pen.

The pen gets detected on supported distros, but the input does not rotate with the screen, so it is unusable in landscape mode. I haven’t found any solution to this problem.

Depends on your DE.

Using Fedora with KDE Plasma on most of my devices, or postmarketOS with Plasma Mobile on ARM64 devices I’m working on. Everything works as you would expect.

Please note that we don’t support X11 at all. It’s dead, please use Wayland instead.

1 Like

Do you know exactly which driver is being used on “supported distros”? Is it the goodix driver, or generic USI or something else?

If anyone has a working USI pen and could share the output of sudo lsmod and sudo lshw would be very helpful.

Here is the output of those commands: felix@fedora:~$ sudo lsmodModule Size Used byuas - Pastebin.com
I tried a couple of distros, the only one that worked without issues was fedora kde. Gnome has the above-mentioned rotation issue.

Yes, that’s a problem with gnome AFAIK.

Someone had a fix for KRANE (also USI):

Sadly, I was not able to get the fix working.

So I managed to get the fix working for my jinlon device, and I will upstream it to libwacom. Where should I document the fix in the meantime?

1 Like

If you could send us a PR on docs repo, it will be much appreciated!

Here is a solution if somebody is still looking for it: Adding documentation to fix USI Stylus rotation. by Xelef2000 · Pull Request #173 · chrultrabook/docs · GitHub
@slacy this might solve your issue

1 Like