How to disable touchscreen on Lenovo Chromebook Flex5i? (LILLIPUP on TigerLake)

I’m currently running ArchLinux with Gnome(wayland), I wanted to disable the touch screen because the touch screen still working after I closed the lid, it just randomly touching things, it also happens on windows, so I’d like to disable it for good, the ID of touch screen is “GDIX0000:00 27C6:0E33”