How I move from MrChromebox RW_Legacy Firmware to Full MrChromebox Firmware

I Have a HP Chromebook G9 EE (Drawlat) and a month ago I succesfully installed the RW_Legacy Firmware and installed Pop_OS! on it. But I don’t dualboot chromeOS so I want to install the Full Firmware on it so I can test more OS like Windows.

Hi Miguel,

Welcome to the forum!

You should be able to run through the instructions as normal to install full rom.

To my knowledge, there’s no need to try to “remove” RW_Legacy as the Full rom essentially replaces the entire base of ChromeOS. This means that anything done before flashing Full rom shouldn’t have any bearing on moving to it.

As always, just make sure to follow Chrultrabook Docs

1 Like

I can install the full rom in Pop_OS! or I have to reinstall chromeOS?

If the script doesn’t give you any errors, you should be able to run it in Pop_OS without issue.

I agree with what Catbirby said- when I installed the full rom on my C13 Yoga, both Fedora and openSUSE installed without issue so Pop!_OS should also install without issue.
Here’s a link to support and documentation for Pop!_OS if you need it:

I try to run it in Pop!_OS but the flasher doesn’t give me the option 2 to flash full firmware, only gives me the option 3 and 4.

Is the option just greyed out?

Have you disabled the firmware write protect on the device? It will tell you in the script.

Try unplugging the battery per the documents, while keeping it plugged in, and run the script.

I Bridged the two jumpers but only gives me this two options

I’m not 100% sure why the options aren’t showing for you, but you might have better luck doing this in ChromeOS then.

Ok, now I need help because when I tried to restore to ChromeOS with the recovery image the process failed and now it keeps showing me this screen on the recovery mode.

I finally decided to flash the MrChromebox Full Firmware manually to the firmware chip with a CH341a Flasher.


Hello, were you successful in updating the firmware using CH341A? Are there any issues I should be aware of?

I have no issues, but you have to disassembly your chromebook and identify your firmware chip in my case was a WINBOND 25Q128JVSM (2.7V-3.6V) search your model in google to verify if it’s a 1.8V or a 2.7V-3.6V, in the case it’s a 1.8V you need an adapter for the CH341A. Once you have all conected to the CH341A you can begin flashing following the instructions here

thank you

I have a Winbond W25Q128FW, which is 1.8v, I also have a 1.8v adapter, but I cannot change the SREG bits to allow me to write (Unlock button on NeoProgrammer etc doesn’t work)

Use the Flashrom tool in a Linux Machine and try again. If it doesn’t work, it could be a problem with your adapter.

I’m assuming it’s the adapter at this point, I have tried on linux too, with the same issue, I wonder if the 1.8v adapter I have may have a wiring issue like the black CH341A programmer I have.