Flashed Lenovo Ideapad Slim 3i Chromebook Now Unrecognized Platform - Unable to Update

Flashed a Lenovo Ideapad Slim 3i Chromebook (PUJJOTEEN15W) with MrChromebox-4.22.0 (12/22/2023) (full rom/UEFI package). Running KDE Neon (ubuntu based) as it seems to support the hardware well.
I do see some strange things - during boot, 0 memory is reported and sometimes system will not find the UEFI files to boot (a power off and waiting a minute or so resolves this).
I went to try and update with a newer version of the firmware but am not able to do so. Running the mrchromebox script gives the following with option #1 to Install/Update UEFI greyed out.

ChromeOS Device Firmware Utility Script [2024-01-07]
(c) Mr Chromebox [email protected]


** Device: ERROR: unknown or unidentifiable device (PUJJOTEEN15W)
** Platform: (unrecognized)
** Fw Type: Full ROM / UEFI
** Fw Ver: MrChromebox-4.22.0 (12/22/2023)
** Fw WP: Disabled


** 1) Install/Update UEFI (Full ROM) Firmware
** [WP] 2) Restore Stock Firmware
** C) Clear UEFI NVRAM


Select a numeric menu option or
R to reboot P to poweroff Q to quit

Any ideas on how to resolve and update?

Thanks,

Chip

I might have ran into the similar issue as you - running the script and getting unidentifiable device on my PUJJOTEEN

But I think I ended up downloading and flashing “coreboot_edk2-pujjoteen-mrchromebox_20231222.rom” manually with flashrom and suzyqable

Have you tried other distros outside of Ubuntu?

Yes, Debian, Kubuntu and Xubuntu. KDE Neon did a great job of recognizing the hardware and I’ve used it previously so I kept it. Don’t use Red Hat or its derivatives.

Bump.

might be an issue with the Alderlake-N
i get the same behavior on my PUJJOFLEX

FW: 4.22.2 (01/20/2024)
Bios register 0 MB of Ram
N100

somtimes eMMC is present - other times its missing
powering off and powering back on a few times will make it come back on
Don’t know if its UFS related or not.
But eventually Windows 11 will load properly – i thought it was sdcard related. doesnt seem like it now.

Do you accept pull-requests? I might try to fix it.

So yeah the fix is obvious, but the consequences are unclear… it happens because of hwid mismatch:

script expects: PUJJOTEEN*-CZPM*

actual hwid: PUJJOTEEN-JQLW...

Thanks, all done Include variation of Lenovo 14e Chromebook Gen 3 by s1gnate-sync · Pull Request #387 · MrChromebox/scripts · GitHub

I’ve just flashed my laptop and can confirm that JQLW works great on new firmware, sound works except sound (on arch linux) which I already fixed using handy GitHub - WeirdTreeThing/chromebook-linux-audio: Script to enable audio support on many Chrome devices script!

1 Like

Hmmm. Script looks broken now. Getting a syntax error near unexpected token ‘)’ error in line 779.

Update - Script fixed now. Still no luck.

Chip

Issue is resolved. Script updated and I was able to update my firmware.

1 Like