Flash chip not detected by SuzyQ + flashrom

I’m in the process of learning how to flash my own firmware with SuzyQ cable. I’ve disconnected the battery, connected to the GSC console by using screen to one of the USB TTY device, and successfully changed the ccd state to open.

However, upon using flashrom to actually interact with the flash chip (trying to read them), the operation fails to recognize the chip, thus failing to read from them:

Found Generic flash chip "unknown SPI chip (RDID)" (0 kB, SPI).
...
Read is not working on this chip. Aborting.
FAILED

Banshee uses Winbond W25Q256JVEM as its AP flash chip and it seems to be one of many devices supported by the raiden_debug_spi programmer. However, the log suggests that it doesn’t get get recognized. The id in the log is full of 0x00 so this suggests that the fault is in the reading, not the matching.

I used @ChocolateLoverRaj ‘s GSC debug board v4.1.0, various flashrom versions (Ubuntu 2304, NixOS’ flashrom 1.3, @WeirdTreeThing 's repo), and various USB-C cables, all with the same result.

I could try it with a WSON-8 probe, but I’m posting here first just in case someone had a similar experience and successfully solved it. Any suggestions?

Here is the log. Thank you in advance!

Thanks! It works as expected now.

I search for en_s5_rails in the source code and it looks like it is related to turning on some power management thing…

Correct me if i’m wrong, but I only used the ‘SuzyQ-cable’ to unlock the chip holding the firmware/bios. It seems to me that you’ve already done that!
Then, from a console within ChromeOS (CTRL-ALT-F2(return button)) after connecting to the internet, you run this in the console:

cd; curl -LO mrchromebox.tech/firmware-util.sh && sudo bash firmware-util.sh

That flashes the right firmware to your device (if supported). So no cable needed anymore! After that you can install the OS you like. But please, carefully read the instructions on mrchromebox.tech

Indeed it is. However, you could also flash the firmware through it! (e.g. in the situation when you can’t even boot).

In my situation, I have successfully installed UEFI firmware with the util script. However I plan to modify the firmware and want to learn how to flash with a Suzy-Q in case I bricked my Chromebook :stuck_out_tongue: