Disabling HWWP on Steelix and similar models

Hello all, myself and a few other users have had issues with disabling WP on Steelix and Rusty (and I believe a few other ARM devices).

None of the flashrom/futility commands are useful as hwwp needs disabled first. crossystem wpsw displays 1.

Disconnecting the battery does not disable hwwp.

I was able to disable with SuzyQ and gsctool but not externally with a Linux machine. This takes forever so I’d like to find a better solution, and not everyone having this issue has a Suzyq cable. Not sure if this is useful but this is what happens when I try with a Linux machine (screen disconnects right after)

Any help would be much appreciated.

What command did you try that resulted in that screen?

sudo screen /dev/ttyUSB0

what happens if you try to disable WP through /dev/ttyUSB0?

I can’t, it displays that output then disconnects from screen.

Edit: it works fine with gsctool disabling internally but like I said I would like to figure out why the battery method isn’t working and if there’s a workaround. At the very least I’d like to be able to disable with SuzyQ and a separate machine

but why are u using screen?

That’s what I know. Is there a method I don’t know?

From the docs:
Run the following commands. This will disable hardware write protect.

echo "wp false" > /dev/ttyUSB0
echo "wp false atboot" > /dev/ttyUSB0

Yes, as I stated that’s the method that works for me. That requires going into dev mode, opening CCD which kicks you out of dev mode, then re-entering dev mode to disable. This takes a long time, which is why I’m trying to figure out 1) why the battery method isn’t working and 2) why I can’t use a Linux machine with a suzyq to disable WP

  1. idk
  2. Because you can’t use suzyq and CCD unless you open the CCD with gsctool -a -o.

That’s not true if you’re doing it with a separate Linux machine, I do it all the time…

Do you need to unplug the battery when you do it all the time?

Oh I see what you mean - since the battery isn’t disabling wp I can’t use the Linux machine

That makes sense. As far as I know, you can enable CCD by either running gsctool -a -o and pressing the PP button or just disconnect the battery.

I was able to do it without a suzyQ cable. I did the following while the battery was still connected:

Enter dev mode
sudo gsctool -a -o
Press PP when prompted
Re-enter dev mode
sudo gsctool -a -I AllowUnverifiedRo:always
^ Above is a capital i
Press PP when prompted
sudo gsctool -a -w disable
Press PP when prompted
Reboot

Interesting. The way I did it on Magneton donated by user “ahorn” was to plug SuzyQ into DUT, open Ti50 console with minicom, and then issue ccd open, press power button multiple times, and then ccd reset factory to make sure it will stay in that state.

It’s quite tedious, but once that’s done you have full CCD access without having to open the machine or mess with ChromeOS.

I was told that in order to use a separate Linux machine with the suzyQ, HWWP needed to be disabled. Are you saying this method doesn’t require that?

And when you say open Ti50 with minicom, can you explain that further? I’ve used the following command in the past when working on an issue with MrChromebox:
sudo minicom -D /dev/ttyUSB1
Would this be the same command, and if so what do I do next?

Write Protect and CCD are two different things :stuck_out_tongue:
On steelix/magneton you have three serial consoles (fourth is empty because it doesn’t have FPMCU).
Open 0, 1 and 2: minicom -D /dev/ttyUSB[0-2] -b 115200

1 Like

I know WP and CCD is different. I was saying that I was told CCD can’t be opened with a separate unit unless WP is disabled. Maybe I’m misunderstanding something though. Thanks for the command, I’ll try it on the next one I test.