Dell latitude 7410 doesn’t work touchscreen and touchpad

Greetings. I came across an interesting situation. Laptop dell latitude 7410, after installing Windows the touchscreen and touchpad do not work and there is one unknown device () in the device manager. All drivers are installed. Yesterday I installed Windows on 5 of the same laptops and everything worked there initially. I hope for your help) PS. I just noticed that in the device manager there are no drivers for the touchscreen and touchpad at all, although all other laptops have them. When I try to install the touchpad driver with coolstar, it is installed, but does not appear in the device manager

It sounds like you’re missing chipset drivers

All drivers have been installed. But unlike other similar laptop models, the manager has an ACPI UCM-UCSI device. No drivers are installed on it. I tried to boot from Ubuntu removable media and the touchscreen works right away

As I said, missing chipset drivers

Do note Ubuntu isn’t even supported, and that Windows is different from Linux

pretty sure they included that to inform that the issue was Windows specific.

Do you think that the problem is not in the bios? I tried installing driver on the chipset from the official website and from coolstar.

without knowing exactly what your Device Manager looks like, in terms of unknown devices and the status on the touchpad/touchscreen devices, nobody can do anything but guess.

Got it, I’ll provide all the information tomorrow

Ah that does make more sense

I have a problem with one driver (in the screenshot), but I’m not sure if this is why the touchscreen and touchpad are not working. I also provided a screenshot with HID drivers, there should be touchpad and touchscreen drivers here. Another screenshot shows that the chipset drivers are installed and working properly

do they work when booting a Live Linux USB?
Boot one and pull a cbmem log

the 2405.0 release firmware for Drallion (6.15.2024) had an ACPI bug which caused Windows to shit a brick and not process the SSDT table at all, leading to the touchpad/touchscreen not working (among other things). I’ve uploaded a new build with today’s date (6.22.2024) which resolves the issue, so please update via the script and verify that the issue is resolved.

thanks, I’ll check it today and write about it

Great, thank you! How can I thank you?

new build works properly for you?