Delay in booting Linux

HI have Kubuntu running on a Chromebook Spin 13 with MrChromebox scripts (almost all hardware works well, after some work-arounds).

After the grub boot entry boots, the boot process seems to stop for up to a minute – with blank (black) screen/ no messages – until the actual boot process/ boot messages appear starts. It seems like the script is waiting for something or there is a timeout or such.

Is there anything I can adjust, or test in order to prevent or lessen this delay?

My current boot options are:

boot=local acpi_osi=Linux acpi_backlight=intel add_efi_memmap intel_pstate=enable i915.modeset=1 tpm_tis.force=1 tpm_tis.interrupts=0 nmi_watchdog=panic,lapic elevator=noop noresume

Linux 6.5.0-17-generic

I also tried sleep / hibernate option, but I loose touchscreen support and have other issues on wake. So I regularly do shut-down.

do you have the same delay in waking up from hibernate?
If not, its worth using it.

I also lose touchscreen after waking up from suspend, but NOT from hibernate. everything works after waking up from hibernate!
My chromebook is acer spin 512, probably same Raydium screen as your Spin13…
my boot time is 25 seconds, and wake up from hibernate 15seconds. running Arch linux.
For me its not about 10 seconds, its about having all my stuff open. its annoying to shutdown and then run all apps again every time.

I didnt find edit post button…just to add, not everything works after hibernate. the sensor for rotation of the screen, and folding it over to tablet mode does not work. so touchscreen works, but its useless

Thanks, unfortunately I do not have enough swap space to try hibernate. I read of a similar issue here: linux - Slow boot process BEFORE boot messages appear - Unix & Linux Stack Exchange, they suggest “it might have something to do with GRUB, or perhaps with the kernel’s earliest interactions with the system firmware” – try grub search commands. Will see if I can dig up anything.

Update: In one of the linked issues on Stack Exchange above, there was suggestion to add insmod progress
to the boot paramaters (link: “boot - How to show progress when loading initrd? - Unix & Linux Stack Exchange”)

I tried this, and it shows more info before the regular boot messages appear.

I can see that for example:
initrd.img-6.5.0-17 75.38MiB

…is being decompressed (78% …etc) and this process is very slow - most likely causing the delay.

However I do not know if / how this part of the boot process can be sped-up.

Any suggestions welcome!