Debian 12 support on ezkinil (3500C)

Hi !
Ready to install a new debian 12 on my acer chromebook spin 514 (ezkinil AMD picasso) with nvme drive and edk2 full rom, I’m stuck to the grub bootloader. Each time an option is selected in the gub, I reboot. Even doesn’t seems to boot any kernel :frowning: . This bug was also present in the non Full rom edk2 stack. I used both dd and rufus to flash debian iso.
Is there any solution to bypass this bug ?

Hi there! I’m having the same issue on morphius (Lenovo Yoga C13 w/NVMe). GRUB loads, then reboots.

I downloaded the Debian nightly installer, and installed Trixie (Debian Testing). Trixie successfully installed but the bootloader partition didn’t get properly recognized, and when I manually entered the GRUB file, same problem- GRUB displays, then reboots in a loop.

I’ve got it uninstalled right now as I was trying other distros: Arch, Tumbleweed, and Fedora all booted and installed as expected. I’m planning on trying a fresh install of Testing again tomorrow to see if I can shed some light on what might be happening, but for whatever reason, Testing’s ISO booted while Stable’s ISO did not.

1 Like

Maybe the version of grub is too old or is missing some feature? Have you tried to boot debian with another distro’s grub?

Oooo, that’s a great idea.

I reinstalled Trixie- same problem. GRUB launches Trixie’s installer successfully but once installed, it just loops. This time I forced installation to the EFI partition, and Coreboot recognized it without issue.

Then I tried using Arch’s GRUB as a rescue- same thing. It gets as far as initrd and then simply restarts the machine. Meanwhile, Arch installs, and then boots from NVMe just fine.

On a lark, I tried Haiku, which happened to do the same thing- restart as soon as the bootloader began loading things. Don’t know enough about Haiku to guess as to what might be the culprit there.

I’m open to suggestions. Might try systemd-boot a bit later.

Hi!
Please try booting the machine with iommu=pt.

PicassoRidge is known for IO-MMU issues due to PSP - including corrupted framebuffer, sound and possibly this issue as well :stuck_out_tongue:

This is not an issue with iommu since I tried with and without it and it just doesn’t work anyway. However systemd-boot works (without the iommu).

No luck with editing GRUB commands to include iommu=pt.

I should mention GRUB is 2.06-13+deb13u1. I don’t know if it’s relevant but GRUB in the Trixie installer ISO I’ve been using is 2.12rc1.13.

Using the 2.12 GRUB from the Trixie nightly ISO, but modifying parameters to boot from the NVMe’s linuz and initrd appears successful, though! I’m currently playing around on a fresh MATE install on Debian Trixie. Audio doesn’t work yet but that was to be expected (haven’t run the neat script from @WeirdTreeThing yet).

So… the GRUB 2.06 used by Debian might have a problem?

That’s really interesting, but not entirely unexpected.

We do state that support for LTS distributions is lacking, as we upstream patches often and expect people to use something that gets updates often (Arch, Fedora, OpenSuSE, Pop_OS! etc).

This is important, because even though those machines are x86 - they do significantly differ from “normal” x86. We’re essentially an x86 equivalent of Asahi :wink:

Debian 12 needs a custom kernel to run on Chromebook/Chromebox if you would have read the docs

Ubuntu and Ubuntu-based distributions that are not based on 23.10 or higher may have issues.

WARNING

Debian versions older than Debian 12 (Bookworm) are not supported. Debian 12 (Bookworm) requires a custom kernel, the audio script will automatically install it for you.

I didn’t flag it as spam just because your info is not helpful, I flagged it as spam because I want you to stop necroposting on threads that have already been resolved or require no further action.