Dead Dell Chromebook 3100s

I have two chromebooks with the same power issue. They both were working but now don’t even post. I plug it in, and there is no charge light at all. I’ve tried them on a Lenovo 65W charger and a Dell 65W charger, and both have the same result.
I tried esc+refresh+power but it doesn’t work, I tried disconnecting the battery and that doesn’t even work with the proper 65W chargers. What’s going on? This has happened before on a third 3100.

Could be a lot of things. You will have to know how to test components with a multimeter and solder to fix anything wrong with it.

Do you remember anything you did before they died?

I don’t know what they were doing before this. Worth noting that one of the 3100s was able to turn on once, I didn’t touch anything, it just sprung to life. It was working fine, but the battery was disconnected so I had to turn it off to reconnect it, and it didn’t turn on again. Maybe it’s the charge port? One of them has a charge port that’s slanted inwards, though that’d require further disassembly.

In that case, could the battery be what’s causing it to not turn on? CBs sometimes won’t boot if the battery is fully drained, but the light should still come on.

In my experience, if the light doesn’t come on then there’s something wrong on the motherboard. Unless of course the light itself is bad.

It should still be able to turn on without a battery, no? That’s how you disable WP on it. On the third one (which has since become a very handy parts machine) I swapped batteries from a working 3100, and nothing changed. The battery from the dead one functioned fine and still held a charge.

Yeah, it should boot without the battery. You said it did boot w/o battery once which is why I thought that might be the issue. Do you have a multimeter?

I do not have one right now, but when I go home I’ll take a look.

One thing you can do w/o a multimeter is check this chip - if it gets really hot then its a bad security chip or embedded controller, which are both BGA chips and difficult to replace

Forgot to post an update on the forums for clarification.

It was one of the most obvious factors (that I overlooked since I thought I had it charging fine before), the charge port being dead. On one of them it roughly functions but not at all on the other. I’ll see if I can get new ports installed.