Crashes on v4.22 (2023.12.24) - Yoga C13 running Linux

Hey! I’m moving my comments under Thinkpad C13 Yoga only 5.7GB RAM available - #48 by bernardo to this thread, as really there’s no reason to have them there.

During a firmware upgrade to v4.22 (2023.12.24), from 4.21.1-4-g28bc0853503, I’ve seen a couple of strange issues, that likely correlate to the Embedded Controller, as seen in the error.

Mainly, after the installation, 5 out of 6 reboots would bring me this error - it couldn’t mount /efi:

This happened using both versions - with trackpad enabled and trackpad disabled.
I was able to capture dmesg and this is the main output. It looks like the error is contained under failed to request DMA:

Since then, I’ve rolled back to 4.21.1-4-g28bc0853503. If you guys have any suggestions, I’m completely available to flash the newest version again. This device is not my main device yet.

From my understanding, the changes between 2023.12.24 and 2023.12.25 are in no way related to this; but if you all understand it make sense to flash latest right away, I’m available.

Thanks for all support and for this awesome community!

1 Like

please verify the problem exists with 1) the latest 12.25.2023 firmware, and 2) on a Ubuntu 2310 or PopOS live USB.

if you’re able to boot the OS with the errors above, please provide a full cbmem and dmesg logs.

@MrChromebox
Here we go: tried latest in Endeavor, got the same error as shown before. PopOS booted fine 1st try. Rebooted, still works.

Pop OS dmesg: [ 0.000000] Linux version 6.5.6-76060506-generic ([email protected]) (x - Pastebin.com

Endeavor dmesg (in one of the times it FAILED boot with the new firmware): [ 0.000000] Linux version 6.6.8-arch1-1 (linux@archlinux) (gcc (GCC) 13.2.1 2 - Pastebin.com

dmidecode: # dmidecode 3.5Getting SMBIOS data from sysfs.SMBIOS 3.0.0 present.Table a - Pastebin.com

cbmem (in a bootable state of Endeavor): coreboot-v1.9308_26_0.0.22-16863-g27dad3f71c Tue Mar 9 05:49:46 UTC 2021 vers - Pastebin.com

cbmem (in a FAILED boot of Endeavor): coreboot-v1.9308_26_0.0.22-16863-g27dad3f71c Tue Mar 9 05:49:46 UTC 2021 vers - Pastebin.com

Hopefully this is enough info.

Thanks!

//Edit: formatting

this sure looks like an issue with the 6.6.8 kernel more than anything. the cbmem logs between the good and bad boot states are identical

Worth to test, let me try using the same minor version as Pop booted. Will update the thread once done.

Oh well. It looks like both LTS and 6.5.7-tkg worked fine. :person_facepalming:

It looks like it’s fixed for now. Will keep you posted if anything.

Thanks!

1 Like

It looks like it isn’t my day, heh.

A couple of reboots - now 6.5.7-273-tkg also is broken, with the same error. LTS looks about right for now. I’m starting to think that this is semi-random, lol

If any update, I’ll update this message and tag you to avoid spamming the forum.

Edit - a day after:
LTS is pretty stable indeed. Also, got hardware acceleration properly by recompiling mesa as per this: chromium: hardware video acceleration with VA-API (Page 37) / Applications & Desktop Environments / Arch Linux Forums

Everything works wonders. Thanks!

Grep dmesg again for any “Call Trace” entries if you can get to a terminal again- you may be experiencing some RAM issues there, but I want to be certain.

For me, Fedora 39 and openSUSE Tumbleweed have booted flawlessly on this hardware, so I also wonder if it’s just the distros being used here?

Both Fedora 39 and Tumbleweed didnt work when i tested. Both had issues OP mentioned. I tried with a bunch of different distros(garuda, ubuntu, opensuse leap15.6 and 15.5), but same result. Finally fedora 38 worked for me(kernel 6.2.9).

Try booting with modprobe.blacklist=cros-ec-uart

On the various Morphius boards that are experiencing this issue, I’m of the opinion they’re going bad.

This is the same issue I have been investigating on my c13. Boot with kernel 6.2.x for now.

There were a significant driver update in kernel from 6.3 with the amd_pstate/acpi. This is a communication layer between the firmware (which is closed source) and kernel. Which makes it hard to debug.

It will just work randomly without an particular error message.
You can verify that this error message should be in your journal til -r? output after a reboot.
“amd_pstate: the _CPC object is not present in SBIOS or ACPI disabled”

On some bios vendors they have this CPPC option to toggle on/off.

Also have seen some possible workaround with grub flags that work for some lucky people.

amd_pstate.shared_mem=1
amd_pstate=passive

Which after kernel 6.3 is set to active by default.

Unfortunately, this has been an ongoing issue with AMD for a long time with various of kernel fixes back and forth.

I have seen fixes in upcoming kernel 6.9 but it was mainly focused on threadripper with possible legacy CPUs on the list.

https://lore.kernel.org/linux-pm/[email protected]/

In my experience this issue occurs when the CPU is left in a state undisclosed from what the amd_pstate should handle.

Best of luck!

2 Likes