Chromebook 516ge, a lot not working with fresh install of windows 11

I have an acer 516ge chromebook. I am running the latest eufi firmware (4.22.0). I just did a fresh install of windows 11, including all the drivers listed on coolstar for this chromebook, including purchased/licensed usb4/tb4 and sof audio drivers. After licensing/installing all the drivers, I also ran windows update. My windows is activated as well.

This is my second time going through this. I recently did a new fresh install on a cb515-1wt chromebook, and that chromebook is working well (sans the internal sd card reader, which I think is a known issue). So I am familiar with the procedure of doing a fresh install of windows 11 and installing all the drivers that coolstar recommends and sells.

On my 516ge, the usbc ports are not working. The audio does not work, and the touchpad (elan0000) does not work. This is obviously a lot not working. Where is the best place to start with diagnosing this? I could just start listing information from the device manager but that would make for a very long post.

I’ve attempted to dump the entire device tree as a series of images. At the bottom is also the audio settings. I cannot select any other audio devices (there is no internal speaker option or headset mic option). If I plug in a headset, nothing changes. I get no sound from either the internal speakers or a headset.

Here my Osiris Device Manager (Win11)

I expanded what looked different between ours

When you replaced your Drive - are you sure nothing got accidently disconnected? like the trackpad ribbon cable or audio wires

were these two working on chromeos prior to flashing to coreboot?

Hey Joe,

I just checked, and nothing is disconnected. I also just did the following:

  1. I flashed back to the google bios and recovered chromeos. Everything worked (usbc ports, sound (headphones and speakers, touchpad).

  2. I installed the alt/legacy firmware and booted a ubuntu LTS live usb. The usbc ports and touchpad worked. No sound, but I never got sound working on any linux with this chromebook.

  3. I flashed to the latest mrchromebox bios (12/22, 4.22.0). When booting the same ubuntu LTS live usb, the usbc ports and touchpad work. No sound, but like I said, sound never worked on linux for this chromebook with any bios that I tried.

So the underlying physical hardware is functioning. I don’t know why windows did not install the various drivers that you have but I do not? I see that I am missing the Intel USB-C Mux, the microphone array, the speakers, the elan touchpad, and hid compliant touchpad.

And even though I have the sof audio, headset and headset mic devices, I don’t get any audio over a headset.

I tried showing the hidden devices, an none of the missing devices turned up. I also don’t have any unknown devices, so there are not devices that I just need to match drivers to as far as I can tell.

And you’re using an official MS downloaded ISO? not some customized one or anything.
I dont know if matters but i am on Win11 23H2 Enterprise

I got the windows install media from microsoft. Attached is an image of the page I used. I used rufus to flash it to a usb. I used the rufus options to disable tpm, secure boot, and to create a local user. It is windows 11 home edition. This is what I have a license/windows key for.


I noticed that the usbc ports are working with windows, but only if the device is plugged in before I boot.

This is random dart throwing, but I remember that I booted off a usbc port when I did the windows install. I wonder if there is something different about usbc driver setup when booting off usbc. I am going to try everything over again, but boot off a usb a port for the windows install usb.

I’m going to re-download everything over again (windows image, all drivers) and give it one more go to make sure I don’t miss any steps.

Can I just install the signed license bins I already have rather than generate new ones? It will be the same cpu and root hard drive. Please answer this question. Thanks.

I don’t have any internet when doing the install. I must have installed the wifi before the usb4/tb4 driver last time, which is out of order. Not sure if that matters.

If there is any info that I can gather while doing my windows 11 install, please let me know.

u can redownload your license file from Coolstar’s License Portal and just drop it in C:\Windows\System32\Drivers before installing the SOF drivers.
As long as the drive hasnt changed and its the same boardname it should work.
or just backup your current one (same directory)

same applies if you bought the TB4 Drivers

Thanks for that!

I tried re-doing the complete windows 11 install and coolstar driver install from scratch, but still having the same exact problem, with the same exact devices missing. What is the process for getting some support for this from coolstar?

The missing devices are USB-C Mux, the microphone array, the speakers, the elan touchpad, and hid compliant touchpad. Not sure why windows 11 is not finding/installing these.

So…you would probably need to generate a
cbmem.exe -c dump [from windows]
and possibly a
dmsg > dump.log [ from ChromeOS or just dmsg dump from Linux Live bootable like fedora konsole] (if its working fine on chromeos or linux)

then hopefully others from the community can analyze whats different on your specific model between the working and non-working logs and request a change on the next iteration of coreboot to MrChromebox or if its something specific to Windows registry - you can make the changes manually as per Coolstar’s recommendation.

At least thats how i was able to resolve some of my issues in the past with different models.
Mind you, I do still have some CB models that are still work in progress (not resolved yet) so it just how it works around here. I know you paid for drivers and expect it to work - which it should since a few of us in the discord have the same model and are working fine. – you might just have that one off model that contains different hardware.

sorry it wont be quick turnaround if thats what you’re looking for either just fyi.

How do I submit the output of these commands? They are too long to copy into a reply (hit a line/character limit), and I don’t see a way to attach a txt file. Should I open a bug?

yeh its a limitation to the forum – i ended up posting it on another filesharing site and linking it here