CAREENA HP Chromebook TPM Initialization Error - is Linux possible?

I have a CAREENA HP Chromebook which displays Secure NVRAM (TPM) initialization error when trying to boot its original Chrome OS installation. I am unable to recover it with Chrome OS as it states there is a problem with the device’s security module. I have tried to reset the TPM module by restarting countless times but no luck.

I was wondering if there is any way to bypass the seemingly broken TPM module by maybe installing a Linux distro? I can’t enable developer mode the usual way as it just reboots to Chrome OS is missing or damaged.


Have you tried holding Refresh and clicking Power? This is like a “hard restart” and it drains all power from the Chromebook EC. I don’t even think you can install anything other than ChromeOS if developer mode is disabled.

Yes I have tried this and unfortunately no success

So there is no way to enable developer mode without a working TPM?

In recovery mode, press tab to show debug info. Upload a picture of that here.

In recovery mode:

The boot error screen:

Are you not able to run chromeos recovery?

No, I get this error

Just wondering, have you ever flashed full rom on this device? If not you could go to the google forums with a valid reason, though idk how helpful those are

No, I have never flashed any unofficial firmware.

Although I was wondering if the TPM is broken then maybe there’s a possibility of doing that and making it usable again?

Custom firmware will ignore the tpm.

How would I go about flashing that without access to developer mode?

You would need an external flasher such as a ch341a.

example of above mentioned flasher

Thanks. I will try this