Can't Boot Linux on Acer Chromebook Plus 515

Hello!

While I have been able to get firmware installed and working on my Acer Chromebook Plus 515, and I have been able to boot many live ISOs and complete the installation of a linux OS, I have not been able to boot any OS successfully.

I know this chromebook has a UFS drive, and given that most of the boot errors indicate that the OS couldn’t find the hard drive, I think maybe I need to figure out how to load a driver/kernel module for UFS at boot (sorry if my terminology is bad, I’m not well-versed in these concepts in linux).

I have tried to look up documentation on configuring the OS to load additional kernel modules at boot, but it didn’t seem to work. But I’m also not confident I did it correctly, either.

Is anyone able to point me in the right direction?

I know you’re trying to do Linux
but I have the same model running Windows 11 - with no issues.

Maybe confirm windows works first - and install Linux over that?

which firmware version are u using?

Worth a shot for testing. Windows did install and boot fine on its own. Had some trouble with some of the drivers but I’m probably not going to use it for Windows, so I’m not too worried about that.

So at least I know the drive works!

MrChromebox 4.22.4 dated 4/16/2024

This forum post got Ubuntu working: boot - Install Ubuntu 22.10 on the computer with UFS(Universal Flash Storage) showing the error "UUID=xxx does not exist. Dropping to a shell. " - Ask Ubuntu

I know Ubuntu is not technically a supported chrultrabook OS, but in case anyone else has this particular model and prefers linux to Windows, this will at least get you into a booting OS.

I’d prefer to be on Fedora so when I can figure out how to translate these steps for that OS I’ll probably post again just so future folks have a guide.

how did you disable the write protect, was there a jumper, screw or was disconnecting the battery enough for this model?

Disconnecting the battery worked for me.

Please attach dmesg from LiveUSB environment.

Sorry if I’m missing an option to just attach this as a text file, but here is the dmesg output when I run it from the Fedora (40) Live USB: [ 0.000000] Linux version 6.8.5-301.fc40.x86_64 (mockbuild@0bc0cc78c12e4762ac - Pastebin.com

mod edit: use pastebin!

Thank you @elly for taking a look!

No worries!
I’m not sure why you have issues, Linux clearly detects the internal storage:

[    9.920907] scsi 1:0:0:49488: Well-known LUN    WDC      SDINFDO4-128G    1432 PQ: 0 ANSI: 6
[    9.925573] ufs_device_wlun 1:0:0:49488: Attached scsi generic sg1 type 30
[    9.926220] scsi 1:0:0:49476: Well-known LUN    WDC      SDINFDO4-128G    1432 PQ: 0 ANSI: 6
[    9.929607] scsi 1:0:0:49476: Attached scsi generic sg2 type 30
[    9.929741] ufshcd 0000:00:12.7: ufshcd_scsi_add_wlus: BOOT WLUN not found
[    9.930204] scsi 1:0:0:0: Direct-Access     WDC      SDINFDO4-128G    1432 PQ: 0 ANSI: 6
[    9.933421] sd 1:0:0:0: Attached scsi generic sg3 type 0
[    9.933725] sd 1:0:0:0: [sdb] 31246336 4096-byte logical blocks: (128 GB/119 GiB)
[    9.933955] sd 1:0:0:0: [sdb] Write Protect is off
[    9.933957] sd 1:0:0:0: [sdb] Mode Sense: 00 32 00 10
[    9.934057] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, supports DPO and FUA
[    9.934058] sd 1:0:0:0: [sdb] Preferred minimum I/O size 4096 bytes
[    9.934059] sd 1:0:0:0: [sdb] Optimal transfer size 524288 bytes
[    9.936412]  sdb: sdb1 sdb2 sdb3
[    9.936485] sd 1:0:0:0: [sdb] Attached SCSI disk

Did you install full firmware?