Cannot restore Dell Chromebook 3110 (Cret) back to Chrome OS

Hello everyone. Before I had this problem, I was running Debian 12 and then I used a firmware backup from a USB with MrChromebox’s firmware script to restore it back to stock. That part was successful. However, now if I try to plug in a Chrome OS recovery usb to restore the OS, it continually tells me “No valid image detected.” I’ve tried multiple USBs on separate ports, and it will keep throwing this error.
Thanks for any type of help.

Try flashing the recovery image to your USB manually, or try using a different USB.

Hello sadlerm, would you mind telling me how to flash the image manually? And I’ve tried using Rufus, among three separate USBs.

Ah, Windows. Yeah sorry I’m not familiar with Rufus options, but that may be the problem you’re having. Try using a different USB image writer program or maybe try a different recovery version.

When I said manually I meant manually downloading the .bin file and writing it to a USB, instead of using the Chromebook Recovery Utility, but it looks like that’s what you’re already doing.

Maybe try the Chromebook Recovery Utility then

I’ve tried using that too, with local images and ones downloaded in it, but it keeps saying no valid image detected.

is the HWID correct or does it say something like CRET TEST?

Yes, the HWID is correct, and it says CRET-BKLL at the bottom.

Just to be certain, you did reinstall the original Chrome OS firmware that came with your Chromebook? The Mr. Chromebox firmware replaces your original firmware with a custom UEFI one that allows you to install ChromeOS FLEX or Linux or etc.

You would have needed to make a backup of the Chrome OS firmware before anything else.

Please forgive me if I didn’t understand correctly.