Cannot boot into Windows on ASUS C523NA Babytiger (Celeron N3350)

Hey,

I’m currently having a problem booting into Windows on my Chromebook. It stays on the logo screen with the loading circle, with no sign of finishing.

It’s an ASUS C523NA Babytiger board with an Intel Celeron CPU N3350 (Apollo Lake). I got the latest full UEFI firmware successfully installed on it (MrChromeBox-4.22.4 04/16/2024). It has the default 64 GB eMMC chip that came with the device.

It did boot the Windows 11 installer when I first tried it out. It went through the installation process, but after it told me to restart it didn’t load up to the OOBE. I tried multiple times to boot into it. After a while, it shows the blue screen of death for DRIVER_PNP_WATCHDOG.

I have created two ISOs of Windows 10 (using MediaCreationTool_22H2.exe and UUP Dump) to see if it was a problem with Windows 11; the same loading issues occur.

It can boot and install into Fedora fine with no issues.

I appreciate any help you can provide. :+1:

Small update:
It could be similar to this problem this person was having but I can’t seem to get it working with the battery in and the power lead on: https://old.reddit.com/r/coreboot/comments/19eqbda/windows_11_only_boots_when_chromebook_is_plugged/

I don’t have time today or tomorrow to open up my Chromebook and disconnect the battery to see if it will make Windows boot (maybe Saturday?). I can try other suggestions given in the meantime.

I decided to just do it today and see if no battery would make it load. No dice. The same outcome with the loading screen and the DRIVER_PNP_WATCHDOG blue screen (for both Windows 10/11).

If there’s anything I should try, then please let me know!

I have seen a message on the chrultrabook Discord about this issue but for a different board and CPU:

I tried looking for the utility this person used to create the CBMEM logs. I haven’t figured out how to do it yet.