Brightness keys not working even after the keyd script

Hello everybody,
This week I got my first chromebook, a HP Chromebook Pro c640 dratini board.
Immediately installed coreboot and arch.

It took me a while to realise I’m supposed to run 2 post install scripts for audio and keyboard. So I did that recently.

But the brightness keys are still not working, do I need to actually set up something myself to change the brightness? Like something that hooks into that key event?

When I do keyd monitor I can see the brightness button events coming in properly so it seems that the script worked fine.

I can control the brightness by echoing into /sys/class/backlight/intel-backlight/brightness so that is working at the very least.

My system is very minimal (64GB emmc), I’m not running a DE or window manager or anything like that to save resources (and learn), I run tmux in fbterm, thats my environment.

Besides that I am having a fantastic time with my chrultrabook thanks everyone who is helping working on this.

I don’t think this is a problem with your Chromebook or the script. The brightness keys aren’t working because you aren’t using a DE. You’ll probably need to set something up. You can boot into a live USB with a DE to test if the brightness keys are working, or just look up instructions on making brightness keys work without a DE.

In my opinion you should just get a DE, even if you want to just use the terminal app in fullscreen.

made two simple bash scripts that I call from a tmux key bind, got it working that way, sadly tmux has no keybind possibility for the brightness buttons so I had to use F6 and F7. but hey, now I have my own brightness implementation which is nice

If you want you can use keyd to rebind brightness keys to f6 and f7