Asus CB3-431 Chromebook - linux installation completing but not booting

I’ve been trying (and seemingly completing) the installation of Mint (tried full and light versions) and Zion OS on my end-of-life ASUS CB3-431 Chromebook, once I complete the installation (using erase disk duration install), when it tells me to remove the installation media and press enter, in doing so, it just comes back with the “ChromeOS is missing or damaged” screen (see photo:

Apologies in advance if this has been asked before, but I’ve completely run out of attempts googling, redditing, and just trying over and over. It feels like I’m either missing a step at the installation stage, something isn’t right with the hard disk or I’m just being a bit thick. Just as a side note, I’ve never tried anything like this before so to have got to the point where I was able to enable legacy firmware installation, remove the write-protect screw etc - I was really pleased with myself until the final hurdle and it just not booting to what I thought was a new installed Linux OS. I’d love to give this machine a chance to be used a bit longer rather than just binned off.

Thanks in advance!

RW_LEGACY is not supported on EOL Chromebooks. I’m guessing you’re not using MrChromebox’s script.

Since you’ve already disabled hardware write protection, to use MrChromebox’s script to install full UEFI firmware on your Chromebook, simply run the script from ChromeOS and select option 2 “Install UEFI (Full ROM) Firmware”

Thanks so much for your reply. It’s going to be a basic question, but how do I run MrChromebox’s script to full install UEFI firmware from the screen that I have shared? I’m at a bit of a loss as to how to do anything now I’ve got to this stage. I’ve never tried doing this sort of hardware salvage before, so I’m learning as I go. As far as I can tell I no longer have ChromeOS. I can get into this screen > and boot of a USB image (like Mint installer or Zion) but I can’t get back to the original ChromeOS. Thank you again!

Can I ask what you did before installing Linux Mint, i.e. how you booted the ISO? It might give me a better picture of whether you’ll need to reinstall ChromeOS first.

I’ve added a bit more information to the last reply just FYI. But originally I went into Dev mode, enabled what I believe was RW_LEGACY, then booted off the USB with mint ISO on, followed the install of mint via the USB (so in the mint test environment) and chose to erase full disk when installing (which is what I understood was the cleanest way to do it). It’s as if I am not installing onto a bootable partition, maybe there’s a bunch of partitions that’s causing an issue. Sorry, I’m not sure how much that helps!

Apologies I didn’t see the screenshot you attached. Yes, that firmware that you’re using is quite old and hasn’t been maintained for quite some time I believe.

No matter, it’s quite simple to reinstall ChromeOS first. Here then would be the steps for how to flash MrChromebox’s firmware instead:

  1. Remove hardware write protection (it sounds like you’ve done this already)

  2. Download and run MrChromebox’s firmware utility script (you can find instructions for doing so here

  3. Like I previously mentioned, you’ll want to pick option 2 - “Install UEFI (Full ROM) Firmware”

Although, if you still can boot live ISOs with SeaBIOS, you can run MrChromebox’s script from a live environment.

I believe Mint doesn’t work because of a kernel parameter that needs to be enabled, but Ubuntu (or any flavour) 23.10 would work.

If this is possible, then you wouldn’t have to first reinstall ChromeOS.

Thanks so much for the replies. I’m going to give re-installing ChromeOS a shot as I know where I am in that environment at least. Just creating an image at the moment, hopefully, it works! This particular ASUS laptop model wasn’t on the list of models typically, but I figured, go for one that’s the same brand and same age - it might work! Will update you on my progress (or lack of!) later. Thanks again.

1 Like