ASUS C434t chromebook making boiling kettle/flying mosquito sounds when plugged in

I recently installed fedora 40 on my ASUS C434t chromebook and it makes a sound similar to a mosquito flying around or a very quiet boiling kettle when it’s plugged into power. I ran a script to make the sound work, and I can now hear things if I have headphones plugged in. However, the computer still makes the sound when plugged in.

What can I do to fix this? Is there any way to fix this?

What kind of battery life do you get? My C434 flip also made a weird sound when charging, but my battery was on its last legs (2-3 hours of charge and suddenly dropping to 0%). Since replacing it, I haven’t had a problem.

Also, you should get sound out of more than just headphones. The internal speaker/built in audio should work too. But there seems to be an issue with newer kernels (6.8.10 and 6.8.11) with Fedora. Sound works perfectly for me on 6.8.9.

I’ve only charged it up to around half but gnome says i have 2-3hrs of battery left.

Also, is there a way to make the volume and brightness keys control volume and brightness? For volume, I’ve manually set the keys and for brightness, I’ve installed light, but it would be nice to be able to have it automatically setup.

well it seems to have fixed itself after a couple reboots

Okay, I found the actual problem. The actual problem is that my weird (probably a fire hazard) power brick is making the noise.

Volume keys on the side worked automatically. Brightness keys (and other chrome function keys) can be done with GitHub - WeirdTreeThing/cros-keyboard-map: Utility to generate keyd configurations for use on Chromebooks

for me, the keys on the side worked fine, but audio is only ever for headphones (if they’re plugged in) and never goes to the speakers.

Use the kernel I mentioned above to fix sound. Use the link I provided to enable function keys.


I just switched to kernel 6.8.5 and ran a script to fix the audio but still, nothing is playing out of the speakers. How can I fix this?

it works! I thought I’d switched the kernel but it turns out I hadn’t