Are their any firmware versions for 32 bit chromebooks

i tried doing the mrchromebox firmware utility script on my chrome book (acer cp311-3h) and i get the error “This script only supports 64-bit OS on Intel -based devices; ARM devices are not supported” are their any alternatives or fixes

There are no 32-bit x86_64 Chromebooks. What is the codename of your Chromebook?

im pretty sure its jacuzzi

There is not custom firmware for that yet.

are people working on it?

No not really. We are all busy and have many other things to work on. You can still install linux with the stock firmware if that’s your goal.

using the dev environment or an actual distro like ubuntu or arch?

If I’m not mistaken jacuzzi is mt8183. That means you’re in for excellent Linux support. Take a peek at this doc and we’ll see what we can do for you :3

1 Like

Yes jacuzzi is mt8183.

Ultramarine or postmarketOS are the best current options.

Lucky you chip!

it doesn’t work. i enabled usb boot rebooted clicked ctrl+u on the os verification screen and all it does make a screen go black and beep

Because you need a usb drive with an os that supports booting with depthcharge.

which os should i use (i tried ultra marine and got the issue i was talking about earlier)

The regular Ultramarine image doesn’t work. You need a special one for your type of chromebook. See the link Jade posted above for more details.

ok thanks