Acer c710 touchpad driver not working

I just got this Chromebook for insanely cheap, and also got some very inexpensive upgrades to go with it to make it usable with Windows 11. I followed all of the instructions on Coolstar’s guide for this model, but I CANNOT get the touchpad to work. The driver installs fine, and there’s no error with the driver on Device Manager, but it just won’t work. I’m on the latest Mr.Chromebox firmware 4.22.4, and used the latest Coolstar touchpad drivers 4.1.6. I’ve even tried to force install older versions of the touchpad drivers (eg 4.1.3) where I saw some people had success.

I know that that this model is “not compatible” with Windows 11 (from Coolstar’s website), but you can see all sorts of people posting success with Windows 11 and a working touchpad. And tbh, Win11 is basically a reskinned Win10.

Any help is very much appreciated!

EDIT: I also tried with a clean install of Windows 10. Latest touchpad driver doesn’t work. 4.1.3 doesn’t work either. Touchpad was working on ChromeOS prior to flashing Mr.Chromebox firmware, and it also works in Ubuntu.

Coolstar did some investigating, found that the vendor/hardware ID for the touchpad got switched in coreboot and updated his driver. Mr. Chromebox also updated his firmware to fix this. No longer an issue. Thanks!