Acer 514 Plus dont boot after Win11 installation

hello everyone!
I’m trying to install w11 using rufus (GPT for UEFI ) 4.4 and 4.5 versión and with oficial Windows media tool creator too, I bypass w11 instalación check, delete alll Partittions and after installlation ends, laptop dont Boot (black screen) and I have to use suzyq to unbrick laptop and flash mrchromebox rom again and repeat the process ( flashrom -p raiden_debug_spi:target=AP -w coreboot_edk2-markarth-mrchromebox_20240415.rom)

Any solution?

reflashing is the nuclear option here, does a hard reset (Refresh+Power simultaneously) do the trick?

Refresh+Power simultaneously doesnt do the trick, stay black screen

Same here:

@WeirdTreeThing can you reproduce?

1 Like

Hi @WeirdTreeThing Regarding this comment made by @MrChromebox if I can help you with anything, please let me know. I have limited knowledge, but I can help.

please don’t tag someone a 2nd time after just a day, it’s impolite

Hello. Yesterday, after reflashing with the Suzyq cable, I managed to get the wonderful rabbit logo to appear again and finished installing Windows 11. There were several blue screens, but I managed to finish. I spent the whole day working fine with Windows and turned the computer off and on without problems several times.

By the way, the Coolstar audio driver works very well. The only driver I had to look for outside was the WiFi driver because Windows doesn’t install it automatically, it seems that the AMD Mediatek drivers have this problem in general. I solved it here: [DRIVERS] AMD|MediaTek WiFi/Bluetooth - Republic of Gamers Forum - 857576

Today, black screen again (refresh+power doesn’t work) when trying to turn the computer back on. Is it possible that the ROM has some small error and randomly causes this? I don’t know if I’ll have to reflash again.

When I unbrick , I do the following commands:
Can you check me if they are correct? All process with jump j35 done.

  1. ls /dev/ttyU*
  2. echo “ccd open” | sudo tee -a /dev/ttyUSB0 > /dev/null
  3. wget https://www.mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-mrchromebox_20240415.rom
  4. wget https://www.mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-mrchromebox_20240415.rom.sha1
  5. sha1sum -c coreboot_edk2-markarth-mrchromebox_20240415.rom.sha1
  6. flashrom -p raiden_debug_spi:target=AP -r badflash.rom
  7. flashrom -p raiden_debug_spi:target=AP -w coreboot_edk2-markarth-mrchromebox_20240415.rom

Today again, after doing the steps above, I was working with Windows 11 without problems. After several shutdowns and restarts, the same situation (black screen without the rabbit logo). It is clear that it can only be solved by unbricking with suzyq.
I imagine that this situation must be caused by some change that Windows makes in the boot system that causes the rabbit not to want to appear on the screen.

I am sorry for the inconvenience caused.

when this happens, instead of reflashing, try just clearing the NVRAM only:

sudo ./flashrom -p raiden_debug_spi:target=AP -E -i SMMSTORE

and see if that resolves the issue. will tell us where the problem is at least

no luck

well, you’re not using the build of flashrom from the docs.

you might try adding --fmap to the command without the ./, but otherwise I’d say use the version of flashrom as per the manual flashing section of the docs

I dont know if is correct, but I add -libpci38 to the command and this is the result:

ubuntu@ubuntu:~$ cd; curl -LO https://tree123.org/chrultrabook/utils/flashrom-libpci38; chmod +x flashrom-libpci38
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1047k 100 1047k 0 0 733k 0 0:00:01 0:00:01 --:–:-- 734k
ubuntu@ubuntu:~$ sudo ./flashrom -p raiden_debug_spi:target=AP -E -i SMMSTORE
sudo: ./flashrom: command not found
ubuntu@ubuntu:~$ sudo ./flashrom-libpci38 -p raiden_debug_spi:target=AP -E -i SMMSTORE
flashrom 1.4.0-devel on Linux 6.8.0-31-generic (x86_64)
flashrom is free software, get the source code at https://flashrom.org

Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
Cannot open lockfile /run/lock/firmware_utility_lockCould not acquire lock.
Error: Programmer initialization failed.

Hi, could you check if the command I entered was correct? I’m sorry for the trouble and time you’re having to spend.

I just noticed you mentioned you had disabled WP via the jumper, that means you have to also disable RO firmware verification since this is a Ti50 device:

so, do this:

  • open ccd via suzyQ
  • ccd reset factory – this will also set AllowUnverifiedRO to Y
  • download and flash latest markarth image (20240710)
    wget https://mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-mrchromebox_20240710.rom
    sudo flashrom -p raiden_debug_spi:target=AP -w coreboot_edk2-markarth-mrchromebox_20240710.rom

then you should be good to go.

I enter the following commands in this order (can you verify it they are correct?

ls /dev/ttyU*

echo “ccd open” | sudo tee -a /dev/ttyUSB0 > /dev/null

3
echo “ccd reset factory” > /dev/ttyUSB0

4
ubuntu@ubuntu:~$ sudo su
root@ubuntu:/home/ubuntu# wget https://mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-20240710.rom

https://mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-20240710.rom
Resolviendo mrchromebox.tech (mrchromebox.tech)… 78.47.63.107
Conectando con mrchromebox.tech (mrchromebox.tech)[78.47.63.107]:443… conectado.
Petición HTTP enviada, esperando respuesta… 404 Not Found
2024-07-12 19:54:51 ERROR 404: Not Found.

root@ubuntu:/home/ubuntu#

I don’t recommend blindly sending commands like that via echo. install minicom (sudo apt install minicom) then, after verifying the ttyUSB devices exist, connect to the CR50 on ttyUSB0:

ls /dev/ttyUSB*

  • ensure ttyUSB0/1/2 are shown

sudo minicom -D /dev/ttyUSB0

then run the commands from minicom:
ccd open
ccd reset factory

exit minicom (CTRL+a, x) then flash the firmware

wget https://mrchromebox.tech/files/firmware/full_rom/coreboot_edk2-markarth-mrchromebox_20240710.rom
sudo flashrom -p raiden_debug_spi:target=AP -w coreboot_edk2-markarth-mrchromebox_20240710.rom

1 Like

Everything is done and looks good. I hope this helps me resolve it. I will keep you posted on the latest news. Thanks in advance for your support and daily effort.

1 Like