Realistic expectations for KANO / Acer Chromebook Spin 714 2003 / CP714-2W-5612

OK, ectool is working and enabled me to check and set the keyboard backlight percentage. This is great!

xyz@deb714:~/Documents/714$ sudo ectool pwmgetkblight
Current keyboard backlight percent: 40

xyz@deb714:~/Documents/714$ sudo ectool pwmsetkblight 10
Keyboard backlight set.

xyz@deb714:~/Documents/714$ sudo ectool pwmgetkblight
Current keyboard backlight percent: 10

@deb714:~/Documents/714$ cat wishlist

  1. DONE F-keys
  2. usb-c (fix doesn’t work - see previous post)
  3. DONE audio fix
  4. external monitor via hdmi (currently a lot of tearing)
  5. turn off the keyboard when its flipped into tablet mode
  6. DONE turn off or dim the keyboard backlight (ectool does it)
  7. bluetooth (haven’t even tried)
  8. DONE ectool
  9. Chrultrabook-Tools (appimage doesn’t run)

For #5 you can use GitHub - ChocolateLoverRaj/tablet-mode-keyboard-light: Automatically turn off the keyboard backlight when a spin laptop is in tablet mode (for Linux). It turns on the light back to how it was before once you rotate back into laptop mode.. It only has a RPM so you at first you can just run cargo b and then run the executable as root to see if it works.

I looked at your github project and it sounded good, but I’m no rust expert and I don’t have cargo on hand. This is debian, so I had to install rpm, but then I could open your .rpm in midnight commander. mc already had cpio support, so I could get into CONTENTS.cpio, and therein find usr/bin/tablet-mode-keyboard-light and copy it to my own bin. I ran it there via sudo, and got the following:

@deb714:~/bin$ sudo ./tablet-mode-keyboard-light
thread ‘main’ panicked at src/main.rs:16:10:
Failed to spawn acpi_listen: Os { code: 2, kind: NotFound, message: “No such file or directory” }
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Note: I really want to disable the keyboard as a whole, in addition to disabling the keyboard backlight, so I don’t type characters inadvertently in tablet mode.

Depending on the desktop environment that you’re using, the keyboard and touchpad should automatically disable when you flip it past 180°. keyd interferes with this so if you try disabling it it should work again.

I have yet to find a proper workaround that isn’t just manually disabling keyd when I want to use tablet mode and reenabling it when using it in laptop mode.

Do you know which specific desktop environments automatically disable the keyboard in tablet mode? I’m currently using lxde. (This isn’t a hard requirement, I’m just used to using it on my raspberry pi machines, and it’s what I used on my previous ex-chromebook - an old Acer CB3-111 that was very underpowered.)

How do I disable keyd? Would it be:

sudo systemctl disable keyd

Another question related to keyd: I chose the install-time option to invert the default so as to have F-keys rather than special keys, though it said that I could get the opposite set via the search key:

printf By default, the top row keys will do their special function (brightness, volume, browser control, etc).\n|
printf Holding the search key will make the top row keys act like fn keys (f1, f2, f3, etc).\n|
printf Would you like to invert this? (y/N)

I actually have a launcher key instead of a search key in place of the caps-lock key, but it seems to work for some things. Like Launcher-Mute gets me mute instead of F8, and Launcher-VolumeDown and Launcher-VolumeUp affect the volume instead of giving me F9 and F10, but Launcher-BrightnessUp and Launcher-BrightnessDown don’t seem to do anything at all.

GNOME and KDE

Also I thought you were talking about the keyboard light, because DEs don’t turn that off automatically.

You need to install whatever package provides the acpi_listen command.

This is awesome

wanting to try gnome or kde, I hoped to install one or more and switch between them

but how? googling led me to the following, which definitely installed the software:

apt install task-gnome-desktop

But I can’t figure out how to switch to gnome. Or how to be presented with a menu upon login that would let me choose each time.

Googling leads me to ~/.dmrc, to ~/.xinitrc, to /etc/sysconfig/desktop, and /var/lib/AccountsService/users as possible places to configure this. Nothing I’ve tried has worked. I’m still lxde.

Suggestions?

Um yeah, maybe use anything but that. It would solve your brightness keyboard shortcut issue too I think. Personally I’ve tested the tablet mode thing with GNOME and KDE and it works.

sudo systemctl stop keyd

OK, I gave up on that and just reinstalled Debian, but this time I chose Gnome, KDE, and LXDE, and now I get the option upon login to choose which one I want. I’m currently using Gnome. I have to do a little bit of setting up of my own software and settings, then I’ll see what chromebook fixes and tweaks I need to do here. I had turned all those I had done before into a script, so I don’t have to start from zero.

This is certainly a process, and I appreciate everyone’s help so far. I’ll keep learning and plugging along.

After reinstalling Debian with Gnome, but before doing the chrultrabook keyboard fix, flipping the screen back into tablet mode DID disable the keyboard.

After also doing the keyboard fix, i got the F-keys I wanted as a default, as well as ALL of the special key meanings working with the Launcher key.

keyd does prevent the disabling of the keyboard when flipped, but stopping keyd let the disabling happen, if that makes sense.

So, everything you’ve suggested to me is working, under Gnome. I’ve not used Gnome before, and its certainly different from LXDE, but the help is extensive and I think I’ll be able to find my way around. Thank you very much.

That turns out to be acpid. So I installed that. I was able to extract the executable tablet-mode-keyboard-light from your rpm package. Running that under sudo from the command line, it worked fine. The keyboard backlight was turned off when the screen was flipped, and it was restored to its previous brightness when un-flipped. Great!

I had installed rpm, so I thought I might be able to just install your package, but I got the following. What am I doing wrong?

@deb714:~/Downloads$ sudo rpm --install tablet-mode-keyboard-light-0.2.1-1.x86_64.rpm 
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
error: Failed dependencies:
	/bin/sh is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	acpid is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	ld-linux-x86-64.so.2()(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6()(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.14)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.15)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.18)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.2.5)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.25)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.28)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.29)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.3)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.3.4)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.32)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.33)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.34)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libc.so.6(GLIBC_2.9)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libgcc_s.so.1()(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libgcc_s.so.1(GCC_3.0)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libgcc_s.so.1(GCC_3.3)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	libgcc_s.so.1(GCC_4.2.0)(64bit) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64
	rtld(GNU_HASH) is needed by tablet-mode-keyboard-light-0:0.2.1-1.x86_64

When I installed the .rpm package on my Chromebook I installed it using the GUI, or using rpm-ostree, so idk about this error.

rpm: RPM should not be used directly install RPM packages, use Alien instead!?

I think you should use “Alien” instead.

sadlerm and ChocolateLoverRaj, here’s a temporary hack to allow me to disable the keyboard and backlight while flipped, and restore them when unflipped.

# script to run before going to tablet mode
#   stopping keyd will allow the keyboard to disable upon flip
#   running  tablet-mode-keyboard-light will turn off the keyboard backlight when flipped and restore it when unflipped
#   just that code is stopped via a ctrl-c
#   keyd is started again

sudo systemctl stop keyd

echo 'Starting the code to disable backlight on flip'
echo '   break out with a ctrl-c as soon as you are done'
# see https://superuser.com/questions/1653229/when-pressed-ctrlc-only-break-out-of-current-function-and-not-whole-bash-script
trap '' INT
(trap - INT; sudo tablet-mode-keyboard-light)
trap - INT

sudo systemctl start keyd

The last time I used any Redhat-like distribution was probably Redhat 5 (more than 25 years ago). So everything about rpm is Alien to me now. I’ll continue googling my way around, but I’ve only got so much bandwidth for new things, as I hop around learning the many things I need to know to get all my wishlist items working. In the meantime, thank you for your app, and for your advice, and my apologies for the ugly hack I posted above.

  1. DONE F-keys
  2. usb-c (fix doesn’t work)
  3. DONE audio fix
  4. external monitor via hdmi (currently a lot of tearing)
  5. DONE turn off the keyboard when its flipped into tablet mode
  6. DONE turn off or dim the keyboard backlight (ectool does it)
  7. bluetooth (haven’t even tried)
  8. DONE ectool
  9. Chrultrabook-Tools (appimage doesn’t run)

Just try Bluetooth. If Wi-Fi works then Bluetooth almost surely works.